REOPEN: Cant send keys

bryangrant4's Avatar


19 Jul, 2012 11:07 PM

I tried several functioning key servers.
1- None of them work from this app, but work from various other utilities.. Cleopatra, AGP..
2- Cant save the list of keyservers.. so I have to manually type in a keyserver everysingle time. Any chance of tweaking this bit of the UI so we can save and re-use key servers at our convenience?

  1. Support Staff 1 Posted by Steve on 22 Jul, 2012 02:56 PM

    Steve's Avatar

    Hey Bryan,

    thanks for letting us know. This doesn't sound good. Are you using the nightly of the Installer or which version are you on? This might be related to libmacgpg which needs to be adjusted for 10.8 and those changes might have broken sth in the nightly version. We're investigating...


  2. Support Staff 2 Posted by Steve on 22 Jul, 2012 04:23 PM

    Steve's Avatar

    Are you running the latest nightly from here: (latest installer is from 4th of june).

  3. 3 Posted by bryangrant4 on 24 Jul, 2012 06:17 AM

    bryangrant4's Avatar

    I just downloaded the latest one. GPGTools-20120318.dmg

    I had this same problem a few months ago.. and just uninstalled.. I simply
    use Thunderbird/Enigmail on a Win7 virtual machine .. using Kleopatra to
    manage keys etc.

    Your app does not seem to do much with key management.. since it cant talk
    to the servers that I usually can use with other programs.. Kleopatra on
    Win/ APG on droid..

    I havent poked around with key management on Ubuntua yet.. but I am sure
    there is a nice package just waiting for me to discover.

    It is just too bad I cant use a Mac to be secure.

  4. Support Staff 4 Posted by Steve on 24 Jul, 2012 03:10 PM

    Steve's Avatar

    Bryan, I'm not sure if we are talking about the same software.

    I posted a link to our nightly versions. Did you follow that link? When you visit that link there is no version called GPGTools-20120318.dmg

    This might be a simple misunderstanding. The latest entry for the GPGTools nightly installer is:

    "GPGTools_Installer-latest.dmg 04-Jun-2012 20:06 23M Untested nightly build"

    You might wanna try that. Let us know if it helps.


  5. 5 Posted by bryangrant4 on 24 Jul, 2012 06:54 PM

    bryangrant4's Avatar

    I will give it a try when I have some more time. Update to follow.

    I just sent you a copy of the filename I downloaded from your site that did
    not work.

  6. Support Staff 6 Posted by Steve on 24 Jul, 2012 07:15 PM

    Steve's Avatar

    Ok, good. Keep us posted.

  7. Support Staff 7 Posted by Steve on 15 Aug, 2012 08:49 AM

    Steve's Avatar

    No further user feedback. Closing.

    @Bryan: Should your problem persist, feel free to re-open this discussion any time.

    All the best,

    Please consider a donation. We do all this in our spare time.

  8. Steve closed this discussion on 15 Aug, 2012 08:49 AM.

  9. bryangrant4 re-opened this discussion on 15 Aug, 2012 07:09 PM

  10. 8 Posted by bryangrant4 on 15 Aug, 2012 07:09 PM

    bryangrant4's Avatar

    It does persist. Please do not consider the matter resolved or fixed.

    The issue persisted in the nightly release/ bug fix you asked me to
    download and try. I do not plan to attempt to use this package any further.
    I simply don't have time to Beta test developmental software, even if it is
    "free". The time involved in support is not free, since time is money.

    Also, IMHO Beta testing nightly patches is time consuming and something
    that I am not qualified to perform since I am not directly involved in your
    development cycle other than as a user.

    I have read some other reviews of this software, and it appears I am not
    alone in this problem. I first noticed the problem several months ago,
    uninstalled that release, instead using the aforementioned Windows GPG
    tools. I revisited the software months later assuming the kinks would have
    been worked out by then. So I giggled whenyou suggested I try a nightly
    release, as if just out of the blue, after all these months, that night's
    release would do the trick. I tried it anyway, since if it did work, I
    would go straight out and by a pile of lottery tickets. ;-)

    Meanwhile, the problem in the software is such that it renders the general
    functionality of GPG key management practically useless since the software
    has no ability to upload to key servers that are usable by other similar

    At the end of the day, I got what I paid for, so I am not really able to
    complain much with any real justification.

    That being said, can you recommend a paid solution for mac that is NOT
    owned by Symantec? I would be happy to spend money on software that works
    and has support. As it is, this package is developmental, and all that it
    implies in terms of Caveat Emptor.


    Bryan "Beau" Grant

  11. Support Staff 9 Posted by Luke Le on 15 Aug, 2012 08:23 PM

    Luke Le's Avatar


    first off let me tell you, it's true, the handling of keyservers could work better, but most of our users don't experience any problem with it.

    We'll definitely work on improving it, but as you may or may not know, we can only work on this project in our spare time, since, as you've noticed, we don't charge any money for it.

    Now that also means that we can't possibly fix the problems users are having as fast as we would like to.

    Some problems are indeed in the software and we can only fix them if we find them.
    Most problems though arise from using the keyserver behind a strict firewall, the keyserver being down or unresponsive.
    To determine what the specific problem is in your case, we'd have to run some debugging on your machine.

    When Steve or anyone else on this support platform asks you to test a specific build, it's not because we don't have time to test it ourselves, or just for the sake of it, but simply because we might have found and fixed your problem in the past and the fix is included in that build.
    We're only trying to solve your problem. If you think it's wasted time to check if the build actually fixes your problem, we apologize.

    We do provide support for our tools simply because we really want our users to be happy with our software.
    We're trying to respond to every request as fast as possible and most of the time problems are resolved promptly.
    We've even logged in remotely on some user's computers to debug their problems on their machines, since we couldn't reproduce them.
    Again, we don't charge money for that either.
    So if you're asking us for a paid solution which also has support, I wonder, what kind of support you expect?

    So to sum it up, I'm really sorry our software didn't work for you.
    If you still wanted to try to fix your issue with our help, we'd be glad to do so, if not, I'll be happy to close this discussion.

  12. 10 Posted by Bill on 16 Aug, 2012 02:45 AM

    Bill's Avatar

    Not sure if this will help or not, but I couldn't upload/update from the key servers either at first. It was defaulted to the sks server I believe. I had to change it to the mit server in BOTH the System Prefs pane and the GPG Keychain Access prefs. It wouldn't work if I only changed one of those, both had to be the same server.

  13. Support Staff 11 Posted by Steve on 16 Aug, 2012 07:30 AM

    Steve's Avatar

    As Luke wrote: key servers can be flakey. There's not much we can do about that. It's not software related, except setup our own. Which would mean even more work and delay in 10.8 compatibility, which is why that is currently out of scope. ;)

  14. 12 Posted by bryangrant4 on 16 Aug, 2012 07:08 PM

    bryangrant4's Avatar

    Understood. Bear in mind, while some servers may temporarily exhibit
    "flakiness", I was attempting multiple servers to rule out that as a
    possibility. AND, while I was attempting to use your package, I would
    then make a similar attempt using Windows based apps like Kleopatra, and
    experienced no issues connecting to key servers.

    Therefore, it does seem likely that problem is directly related to your
    application and the manner in which it attempts to connect to key servers.

    Also, why in the world doesn't the connect to key server dialogue
    provide for a way to store more than key server address, perhaps in a
    pull down menu?

  15. Support Staff 13 Posted by Luke Le on 16 Aug, 2012 07:17 PM

    Luke Le's Avatar

    Use this terminal command to add a keyserver:

    defaults write org.gpgtools.common keyservers -array-add Server2

    Replace Server2 with the actual keyserver URL of course.

    After that restart GPG Keychain Access and select it from the provided keyserves.
    DON'T change the keyserver in GPGPreferences afterwards, since the two preferences are currently not in sync (might be a known bug, but unfortunately at the moment we have no time to fix it, since we only do this in our spare time)

  16. 14 Posted by bryangrant4 on 16 Aug, 2012 07:24 PM

    bryangrant4's Avatar

    Actually that did the trick..

    However, we really should have better UI for managing key servers. The
    GPG Keychain Access prefs will not store more than one key server for
    later or subsequent use.

  17. Support Staff 15 Posted by Luke Le on 16 Aug, 2012 07:29 PM

    Luke Le's Avatar

    Yes, we know. And we will completely rewrite GPG Keychain Access focusing specifically on usability. But again, this all happens in our spare time.
    We're trying to find someway to keep the tools free (if possible) and finance development.
    Let's hope we succeed.

  18. Support Staff 16 Posted by Steve on 18 Aug, 2012 03:04 PM

    Steve's Avatar

    I've attached ticket to this discussion. Feel free to subscribe to the ticket in order to be notified of changes.

    All the best,

  19. Steve closed this discussion on 14 Sep, 2012 02:47 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac