10.8: Imported key processed successfully but not in list

ML's Avatar

ML

07 Jan, 2014 04:46 PM

I am using GPG Keychain Access version 1.1.3 (601) on Mac OS X 10.8.5

A friend sent me their public key (.asc file).

I attempted to import the .asc file with GPG Keychain Access. Message said "Count of processed keys: 1" which I assume means it worked. However, the key does not show up in my list and the number of keys listed is still the same.

This has happened to both my colleague and I whilst attempting to import various asc files.

Suggestions?

  1. Support Staff 1 Posted by Steve on 07 Jan, 2014 04:47 PM

    Steve's Avatar

    Hi ML,

    could you please attach one of those pub keys produce this issue so we can test against that?

    Could you also please download and install our latest nightly build and see if the problem persists.

    All the best, steve

    Disclaimer: This is a development version which has not been thoroughly tested yet, so bugs or crashes are to be expected. Thanks for helping us test this fix.

  2. 2 Posted by ML on 09 Jan, 2014 04:46 PM

    ML's Avatar

    Hi Steve,
    I have attached said pub key.

    I tried installing GPG Suite via the link you gave me, however, the Installation does not complete. It seems to stick with only a few minutes left. (upon several attempts) I even left it for maybe 4 or 5 hours to see if it would eventually work. Nothing.

    Now when I opened my GPG Keychain Access program all the keys I had are gone. When I try to import any key it says:
    "Key Import Failed Import failed!
    Code = 0
    Error text: "

    Help!

  3. Support Staff 3 Posted by Steve on 11 Jan, 2014 06:49 PM

    Steve's Avatar

    Hi ML,

    1) Sorry, our nightly installer suffers from a glitch we are investigating right now. So please go back to the stabel installer. Same procedure: download from our homepage, mount the dmg, run the uninstaller and then re-install.

    2) Thanks for attaching the pub key in question. This key suffers from a missing self-signature and thus cannot be imported in GPG Keychain Access. Notice that GPG Keychain Access, after it's finished trying to import that key says: "Count of processed keys: 1". After a successful import it would actually say something like: "Count of imported keys: 1".

    While we indeed should be more specific about why the import failed, above is the reason. Please ask your contact to create a new proper key.

    All the best, steve

  4. 4 Posted by ML on 13 Jan, 2014 04:20 PM

    ML's Avatar

    Hi Steve,
    Thank you for your help. The GPG Suite has successfully installed and Keychain Access is now working again.

    Several of my contacts have sent me pub keys from their hushmail accounts. 2 out of 3 have been processed but not imported in Keychain Access. The first was imported and has worked since however, so I know it can work.

    Any ideas as to why these two keys are not working or "missing their self-signature"? This is not only a problem for me trying to get their pub keys. Both of them themselves are unable to import their private and public key from hushmail to Keychain Access.

    Any suggestions on how to fix this would be greatly appreciated. Thank you!
    ML

  5. Support Staff 5 Posted by Steve on 15 Jan, 2014 03:02 PM

    Steve's Avatar

    Hi ML,

    we did create a test account on hushmail to see what the pub keys they export do look like. We receive a perfectly self-signed key and were abel to properly import that pub key into GPG Keychain Access no problem.

    I suggest you ask your contacts to create a new key pair to make sure they have working public keys.

    All the best, steve

  6. Support Staff 6 Posted by Steve on 17 Jan, 2014 08:21 AM

    Steve's Avatar

    The installation issues with the nightly build are now fixed. Feel free to give it a try.

    I'm closing this discussion. If you need further assistance or have questions you can re-open this discussion here or open a new one any time.

    Best, steve

  7. Steve closed this discussion on 17 Jan, 2014 08:21 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac