10.7: gpg-agent timeout (was: I think I clobbered my Certificates)

shorbus's Avatar


17 Dec, 2013 10:26 AM

GPG Keychain Access

Please describe your problem. Add as much detail as possible.

When I try to send an email (signed and encrypted), I get the following: (see "untitled 2.tiff")
If I try to revoke the certificate, I get another error (see "untitled 3.tiff")

If you remember, please describe the steps leading up to the problem

This all happened because, as a naive newbie, I set up a key pair for an email account to test things. The email account has since gone away, and I was able to revoke the certificate for it (I now understand it can never be deleted...). Then, I set up a new key pair. However, in the intervening time, I have moved, gone through a lot of life's issues, etc.... and, I no longer remember my passphrase, and I cannot find it in my keychain. So, I can no longer use that key pair. Hence, my effort to revoke the certificate. But, that doesn't work.

So, I've gone from a naive newbie to an embarrassed newbie. What do I do now?


  1. 1 Posted by shorbus on 17 Dec, 2013 10:51 AM

    shorbus's Avatar

    Only one file loaded. Here is the other file (regarding revoking the certificate).

    I also tried to revoke the key, and got an error. I tried changing the passphrase and expiry date, and got errors.

    The version of GPG Keychain access is 1.1.3 (601).

    Question: what is the difference between revoking a key and generating a revocation certificate? I saw the explanations for the procedures, so I understand that part, but I do not see an explanation for the differences in effect.

    Thanks, again!

  2. Support Staff 2 Posted by Steve on 17 Dec, 2013 11:26 AM

    Steve's Avatar

    Hi Shorbus,

    first off: no need to be embarrassed. At one point or another everybody starts as a noob. Second off: this happened to me as well.

    We need to take better precautions and the following ticket is a first step which we yet need to implement: https://gpgtools.lighthouseapp.com/projects/65684/tickets/205

    This KB-article covers your problem. I suggest reading this to better understand what is going on: http://support.gpgtools.org/kb/faq-gpg-keychain-access/how-to-revok...

    Let me know if that was helpful.

    Best, steve

  3. 3 Posted by shorbus on 17 Dec, 2013 06:38 PM

    shorbus's Avatar

    Hi, Steve,

    Thanks for the rapid response.

    I used that article as my guide for the steps to go through. I tried it again just now. I still get the same error messages.

    It appears that I have a UserID and email address that I cannot revoke, or modify. I do not seem to be able to add a new key for it, either.

  4. Support Staff 4 Posted by Steve on 01 Jan, 2014 07:56 PM

    Steve's Avatar

    Shorbus, could you please download and install our latest nightly build and see if the problem persists.

    All the best, steve

    Disclaimer: This is a development version which has not been thoroughly tested yet, so bugs or crashes are to be expected. Thanks for helping us test this fix.

  5. Support Staff 5 Posted by Steve on 16 Jan, 2014 03:35 PM

    Steve's Avatar

    We've a ticket for this problem:


    We're investigating and will re-open as we have news.

    If this discussion get's closed, it will be re-opened as soon as the ticket is closed so you'll receive a notification. Feel free to open a new discussions should you run into further problems or need assistance.u

  6. Steve closed this discussion on 16 Jan, 2014 03:35 PM.

  7. Steve re-opened this discussion on 25 Jan, 2014 03:02 PM

  8. Support Staff 6 Posted by Steve on 25 Jan, 2014 03:02 PM

    Steve's Avatar

    Shorbus, do you happen to have some time? We are looking into this problem right now and it would be great to have a user with this problem.

    If you have a few minutes please hop on our live-chat: http://www.hipchat.com/gi8zHW4K3

  9. Support Staff 7 Posted by Steve on 26 Jan, 2014 10:00 PM

    Steve's Avatar

    Could you please download and install our latest nightly build and see if the problem persists.

    We've fixed the gpg-agent timeout issues now! Yey °/

    All the best, steve

    Disclaimer: This is a development version which has not been thoroughly tested yet, so bugs or crashes are to be expected. Thanks for helping us test this fix.

  10. 8 Posted by shorbus on 28 Jan, 2014 12:44 PM

    shorbus's Avatar

    I got it, Steve.

    I think I found a bug. I was just composing an email in an account that is not covered by my key. About every 20 seconds I got a message saying that it could not be encrypted (which I was not trying to do -- the encryption "padlock" icon showed open. The "OpenGP" indicator in the corner is greyed out. I am using Apple Mail.

    All that said, I'm not getting the message as I compose this email (which is also not covered by a key)... hmmmm.... The joys of debugging (been there...).


  11. Support Staff 9 Posted by Steve on 29 Jan, 2014 07:27 PM

    Steve's Avatar

    Shorbus, known and fixed already.

    Please re-download the nightly (yet again). Should no longer happen :)

  12. 10 Posted by shorbus on 31 Jan, 2014 02:01 PM

    shorbus's Avatar

    Hi, Steve,

    I'm still getting messages saying the email could not be encrypted. This is happening when I am writing an email (Mac Email program), but using an email account that does not have a gpg key set up. It also seems to be intermittent.


  13. Support Staff 11 Posted by Steve on 31 Jan, 2014 02:05 PM

    Steve's Avatar

    Which version of GPGMail do you see when you go to Mail.app > Preferences > GPGMail?

  14. 12 Posted by shorbus on 31 Jan, 2014 02:41 PM

    shorbus's Avatar

    Version: 2.1 (7c59d39)
    Build: 618n


  15. 13 Posted by shorbus on 31 Jan, 2014 03:05 PM

    shorbus's Avatar

    I'm also getting a message every time I send an email to a person who has a key, that I email frequently. It tells me that I do not have his key, and I do not have my key, so the email cannot be encrypted. If I refresh both keys, it seems to work fine. I just tried sending it without refreshing the keys, and it went. I don't know if it was encrypted or not. FYI, these messages to refresh the keys can be just a couple minutes apart. And, they happen in the middle of composing the email, not when I'm pressed "send".


  16. Support Staff 14 Posted by Steve on 31 Jan, 2014 03:07 PM

    Steve's Avatar

    Just to make sure you are on all the latest tools: could you run the uninstaller that comes with the nightly release and then re-intall.

  17. 15 Posted by shorbus on 31 Jan, 2014 05:18 PM

    shorbus's Avatar


    I had not uninstalled it previously, so I did it as you requested -- I uninstalled it, and reinstalled it. I'm still getting the same messages. In my most recent encrypted email, I was getting it about every 30 seconds, and it would not send it until I refreshed the keys.


  18. 16 Posted by shorbus on 04 Feb, 2014 08:15 AM

    shorbus's Avatar

    My error. It says "No recipient specified." This is from an email account that is not included in my Keychain, and to an account where I do not have a key (thus, no entry in my keychain).


  19. 17 Posted by shorbus on 04 Feb, 2014 08:33 AM

    shorbus's Avatar

    Hi, Steve,

    Whenever I compose a message that is not from or to an address in my GPG Keychain, I get an error message that says the encryption failed because it is an unknown recipient. The problem, though, is that I now get this message about every 15 seconds. It means I have to stop composing the email to clear the message, then type rapidly to get as much said before the process repeats.

    Do you have any suggestions?


  20. Support Staff 18 Posted by Luke Le on 04 Feb, 2014 12:42 PM

    Luke Le's Avatar

    Hi shorbus,

    you had to do this quite often already, but could you please install the latest nightly.

    This bug should be fixed in that version.

  21. Support Staff 19 Posted by Steve on 03 Mar, 2014 02:24 PM

    Steve's Avatar

    No further user feedback. Closing.

    shorbus, should your problem persist, feel free to re-open this discussion any time.

    All the best, steve

  22. Steve closed this discussion on 03 Mar, 2014 02:24 PM.

  23. Steve closed this discussion on 20 Jun, 2014 11:23 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac