NSCFString appendString: nil argument

jakob's Avatar


20 Oct, 2013 08:24 AM

Which of our tools is giving you problems?


What’s the version of that tool?

2.0.3 build 512

What version of OS X are you using?


Please describe your problem. Add as much detail as possible.

I have a really old GPG key for one of my email addresses (from 2001). I have not been using it for email for quite a while (since upgrading to Mountain Lion), but needed GPG recently. However, I cannot sign mails with this key, I get the error "Signing your message failed because an unknown error has occurred [ ... ] -[__NSCFString appendString:]: nil argument" (see attached screenshot)

I suspect this may be due to an UTF-8 character in my name in the key. The key was created on the command line in a Linux environment back in 2001. The offending letter is displayed as ? by GPG Keychain Access. And by the way, I cannot edit the key because I get the same error.

The problem is not urgent: I have disabled per-default signing and my current signing/encryption needs are with another key. But I would like to get this fixed before I need this key again :)

Best regards


  1. 1 Posted by jakob on 24 Oct, 2013 07:14 AM

    jakob's Avatar

    I just updated the GPG Suite (so GPGMail is now 2.1). The problem is still present.


  2. Support Staff 2 Posted by Luke Le on 31 Oct, 2013 03:38 PM

    Luke Le's Avatar

    Hi Jakob,

    Is there any chance we could debug this problem directly on your system using TeamViewer?
    Since this is related to a special key of yours, it will be very hard to reproduce this problem on one of our systems.

    Please let us know if that's an option for you and if so, you'll need to have Xcode installed.

  3. Support Staff 3 Posted by Luke Le on 06 Nov, 2013 10:38 PM

    Luke Le's Avatar

    Hi Jakob,

    we've found the problem and seems to be indeed related to UTF8 characters in the user ID. Unfortunately we can't reproduce it on our system, so I think it might be related to older keys.
    But a fix is possible and should not take too long.

  4. Support Staff 4 Posted by Luke Le on 06 Nov, 2013 10:39 PM

    Luke Le's Avatar

    Could you try to run the following command in Terminal:

    gpg -sa

    and let us know if the pinentry dialog which asks you for your passphrase is empty?


  5. 5 Posted by jakob on 08 Nov, 2013 09:13 PM

    jakob's Avatar

    Dear Luke,

    I found a solution to my problem: I edited my key with gpg on the command line, added a new user ID with my name without an UTF-8 character, and remove the old user ID. That solved the problem.

    If you want me to try out debugging the problem, then I can dig out a backup of my .gnupg directory from a Time Machine backup once I get back to work on Monday, and try "gpg -sa".

    Best regards


  6. Support Staff 6 Posted by Steve on 15 Nov, 2013 12:37 PM

    Steve's Avatar

    Hi jakob,

    this bug should be fixed. Could you please download and install our latest nightly build and see if the problem persists.

    All the best, steve

    Disclaimer: This is a development version which has not been thoroughly tested yet, so bugs or crashes are to be expected. Thanks for helping us test this fix.

  7. Steve closed this discussion on 15 Nov, 2013 12:37 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac