Is there a GPGMail version for Lion?

t.a.docter's Avatar


17 Nov, 2011 01:07 PM

"Will GPGMail run under OS X Lion 10.7? A pre-release version, yes. We are working on it." What kind of answer is this??? Yes or No will do... So what is it?

  1. Support Staff 1 Posted by Steve on 17 Nov, 2011 01:48 PM

    Steve's Avatar

    Dear Docter,

    not sure why you choose this rather unfriendly style. You are free to use our software. We offer it free of charge. You are also free to give the closed source PGP Desktop version for 99$ a try:

    Besides that, you want an yes-or-no-answer for a question which can't be answered that way.

    But yes, many of our users are happily using our pre-release and consider it rather stable. One user wrote back that our pre-release was running better than PGP Desktop official stabel release. I'm not here to judge about that. I can only encourage you to give the GPGTools Installer a try. Let us know how it works for you and feel free to ask if you need help. We will happily assist in setting this up.

    We are hard at work on a beta release and if you are not familiar with software development: those are standard steps on the way to a release which then can be called stable.

    Hope this helps,

  2. Steve closed this discussion on 17 Nov, 2011 01:48 PM.

  3. Docter, T.A. re-opened this discussion on 17 Nov, 2011 04:02 PM

  4. 2 Posted by Docter, T.A. on 17 Nov, 2011 04:02 PM

    Docter, T.A.'s Avatar

    Dear Steve,
    Sorry for my unfriendliness, I have given the GPGTools installer a try but was confused if this was the Pre-Release or not.
    However I am now even more confused because implicitly you are saying the GPGTools Installer is the Pre-release while it's not working on my Mac, Mail does not get an extra option in de drop down menu Message or View. And so the lock is greyed out in a message.

    Thank you for your quick response, I will google further and try to get it to work.
    God bless,
    Tycho Docter

  5. Support Staff 3 Posted by Luke Le on 17 Nov, 2011 04:09 PM

    Luke Le's Avatar

    Hi Tycho,

    we're a very small team, 4-5 working actively on this project, and that's the main reason why at the moment most products are in pre-release stage.
    As Steve already said, the products work well for a lot of people already, that's why we're releasing those pre-versions, because a lot of people also rely on them and the commercial version is not exactly there yet for Lion either.

    If you have a valid key to sign & encrypt which matches your mail address as configured in you should be able to click the sign button (next to the lock). If you also have the public keys to one or more of your recipients, you should be able to click the lock button.

    If you open GPG Keychain Access it should be easy to see if you have those keys.

    Please give this thing a little patience until we find the time to come up with some proper documentation and screencasts and just keep asking, we're always glad to answer and try to do so as quick as possible.

    Thanks for understanding,


  6. Support Staff 4 Posted by Steve on 17 Nov, 2011 04:11 PM

    Steve's Avatar

    Luke you beat me on this ;) but I still post my reply cause it contains some informative links:

    Hey Tycho, no need to google further. We're here to help.

    first it is important to understand that the installer is a shared installer for all the tools we offer and since e.g. GPGMail relays on MacGPG it is very user friendly to offer such an installer. Now, for 10.7 GPGMail is currently in it's alpha stage (but rather stable as I wrote). That doesn't make the installer a pre-release. It's official but it means that if you are on 10.7 the installer will select GPGMail 2.0a4 (the current alpha).

    Hope this explains what's going on.

    I am not sure what the problem with your installation is (or if there is one at all). Could you have a look at the screenshot here:
    That's how things should look like. The box for encryption will only become active if you enter a recipients mail address for which you have a public key. Otherwise you won't be able to encrypt the mail.

    Also a first nice read on what is what might be:

    Does this answer your questions?

  7. Steve closed this discussion on 17 Nov, 2011 04:11 PM.

  8. Alex re-opened this discussion on 17 Nov, 2011 05:27 PM

  9. 5 Posted by Alex on 17 Nov, 2011 05:27 PM

    Alex's Avatar

    Hi there,

    I also want to add that there is a screencast that should show how to start with GPGTools at - hope this helps a bit.

    Best regards, Alex

  10. Steve closed this discussion on 17 Nov, 2011 05:34 PM.

  11. Docter, T.A. re-opened this discussion on 17 Nov, 2011 07:02 PM

  12. 6 Posted by Docter, T.A. on 17 Nov, 2011 07:02 PM

    Docter, T.A.'s Avatar

    Hi Alex,
    Thanks for your great response, I give my regards to Luke and Steve too.

    As the video shows it should be a matter of seconds to install… The lock however stays greyed out?
    [cid:[email blocked]]

    I have tried it on multiple Lion machines with the same result.

    Bless all of you,
    Tycho Docter

  13. Support Staff 7 Posted by Luke Le on 17 Nov, 2011 07:07 PM

    Luke Le's Avatar

    Hi Tycho,

    if you look at the screenshot you attached you see that you're gpg key uses your address while the account you want to send from is your address.

    If you want to use that address you need to add that email address to your key in GPG Keychain Access.

    You can do so by right clicking your gpg key in GPG Keychain Access, click on Details and select the tab reading "User IDs".
    Pressing the "+" icon you can add your email address.

    After going through these steps you have to restart and you should be good to go.

    Hope that helps

    P.S.: In future GPGMail versions this will be way less tedious.

  14. Support Staff 8 Posted by Steve on 17 Nov, 2011 07:09 PM

    Steve's Avatar

    Hey T.A., this is very helpful. The more info you provide the better the analysis you'll receive.

    Also, despite Luke beat me again with his response ;), some more info:

    From what I can see on the image you are writing a response to Tender. You do not have (and there isn't one) the public key for that.

    Try opening a new mail and enter Mr. B. (who's puc key you have in your keychain). Most likely you'll then be able to encrypt and sign. Could you give that a try?

  15. Steve closed this discussion on 17 Nov, 2011 07:10 PM.

  16. Docter, T.A. re-opened this discussion on 18 Nov, 2011 09:37 AM

  17. 9 Posted by Docter, T.A. on 18 Nov, 2011 09:37 AM

    Docter, T.A.'s Avatar

    Hi Alex & al,
    I have installed it on OSX 10.6.8 and here it is working.
    On Lion 10.7.2 it is not working.

    Grt, Tycho

  18. Support Staff 10 Posted by Steve on 18 Nov, 2011 10:25 AM

    Steve's Avatar

    Hmm, I can't tell from that info where the issue is. From what I read so far, it looks like everything is working as expected. Could you try the following:

    • close
    • open GPG Keychain Access on your Lion machine
    • search for my key (Steve Bell), the one created 2011-06-16
    • import that key
    • open mail
    • create a new mail and enter steve AT as recipient
    • see if you can encrypt the message
    • feel free to send me that test messsage so I can "test back" and see if I can encrypt to you

    All the best,

  19. 11 Posted by Alex on 18 Nov, 2011 10:59 AM

    Alex's Avatar

    Also currently you need an own OpenPGP key for exactly the mail address you're currently using (i.e. the sender mail address). As you can see in our screencast the plugin is actually working - we now have to identify what the issue might be with your configuration.

  20. 12 Posted by Alex on 15 Dec, 2011 09:14 AM

    Alex's Avatar

    No response. Closing.

  21. Alex closed this discussion on 15 Dec, 2011 09:14 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac