GPG Services: Issues with decryption

TKBK's Avatar


19 Mar, 2022 02:13 AM

Im having trouble decryoting a basic text file with just text. It is a file from "TextEdit"on Mac. I am able to encrypt the file and everything, but when it comes to decrypting any file, it givesme an error "Decryption failed: No Data! (No data)
Code = 58".

Please assist if any thoughts or insight comes to mind.

  1. Support Staff 1 Posted by Steve on 19 Mar, 2022 08:23 AM

    Steve's Avatar

    Hi TKBK,

    welcome to the GPGTools support platform. Sorry to hear you are having problems using GPG Suite.

    To exchange OpenPGP messages use the Plain text format (txt). Can you please double check you are not using the proprietary rtf format. To switch to txt open TextEdit > Preferences and select the "Plan Text" option.


  2. 2 Posted by TKBK on 19 Mar, 2022 10:53 AM

    TKBK's Avatar

    Omg that worked! Thank you Steve I love you! Have a great day.

  3. Support Staff 3 Posted by Steve on 19 Mar, 2022 11:28 PM

    Steve's Avatar

    Glad this is solved for you 🙌

    I'm closing this discussion. Should you need further assistance or have questions you can re-open this discussion here or open a new one any time.


  4. Steve closed this discussion on 19 Mar, 2022 11:28 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac