No installing in Mac OSX Monterey v12.1

Fernando Montoya's Avatar

Fernando Montoya

27 Dec, 2021 04:00 PM


Developer that uses GPG as sign software for Git.

I had GPG Tools installed in OSX Monterey 12.0, today I installed the latest version, v12.1, after restarting the computer and login again I made some changes in my code and tried to commit:

git commit -S -m "foo"

Unfortunately this command just hanged, I killed it and start debugging the problem.

After running it with GIT_TRACE=true and got this command:

gpg --status-fd=2 -bsau DCA611273C3A07D0012294B42023B961E6A97F4B

I ran it and the output was:

gpg: waiting for lock (held by 292939)

This give me a hint that the gpg process was busy with something else, so I tried to open it from the System Preferences panel, it was my surprise when it didn't open at all.

So, I tried to download the latest version GPG_Suite-2021.3, but after going through the installation wizard it gets stuck in the "Running package scripts", just showing "Install time remaining: Less than a minute", been showing this message since 40 minutes ago.

I tried to quit the installation process but OSX says that it can because "The Installer is busy", so I ran the Uninstall wizard from the GPG Suite .dmg image, it runs successfully and also unblocks the installer, the installer now says that everything went just fine :D.

After that I restarted the computer and tried again to install it, finding myself in the exact same position with the same problem.

Not sure what else to try.

It is there a way to run it manually from the terminal?


  1. 1 Posted by Fernando Montoy... on 27 Dec, 2021 04:34 PM

    Fernando Montoya's Avatar

    Good news!

    After renaming ~/.gnupg to something else, the installer finished.

  2. Support Staff 2 Posted by Luke Le on 01 Jan, 2022 10:22 PM

    Luke Le's Avatar

    Hi Fernando,

    very glad to hear that you managed to figure this one out.
    Should this happen again, it's not necessary to move the whole ~/.gnupg folder, but instead it should suffice to remove any .lck files within the gnupg folder.

    Closing this discussion. Feel free to open a new one at any time should you have questions or run into problems.

  3. Luke Le closed this discussion on 01 Jan, 2022 10:22 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac