GPG error when using gpg-agent with Yubikey GPG applet on Big Sur from Mail

pieter.vandermeulen's Avatar


12 Apr, 2021 02:42 PM

Which of our tools is giving you problems?

GPG Mail plugin 5.0 build 1569 when using gpg-agent with Yubikey gpg applet

Attach a screenshot of the version info for all installed components (how to:


Describe your problem. Add as much detail as possible.

My GPG encryption and signing keys are on my yubikey. I used gpg2 from GPGTools to create these keys on the yubikey.
The problem is that GPG signing and decrypting from OSX Mail does not work unless I "wake" it first by doing something with the card (i.e. my Yubikey) from gpg2. A simple gpg2 --card-status is enough to make it work: I get prompted for PIN when necessary and the mail is signed or decrypted. If I do not do that I get a gpg: signing failed: Invalid ID error (see screenshot).
I also use the authentication key in the gpg applet with the OSX openssh. This does work without having to "wake" the card first. I'm not using the PIV applet.


pinentry-program /usr/local/MacGPG2/libexec/
default-cache-ttl 600
max-cache-ttl 7200

enable-ssh-support write-env-file use-standard-socket

What did you expect instead

I expect that signing and decrypting works as long as the yubikey is connected, prompting for PIN when necessary.

Describe steps leading to the problem.

The problem is triggered when the card (Yubikey) has been inactive: after sleep or after inserting the token.

Are you using any other plugins?


  1. 1 Posted by pieter.vanderme... on 16 Apr, 2021 10:03 AM

    pieter.vandermeulen's Avatar

    I see now that this issue has been reported before:

    I updated to the latest nightly (3004n) and that seems to have fixed it.

  2. pieter.vandermeulen closed this discussion on 16 Apr, 2021 10:04 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac