How to configure MDC use with GnuPG Gpg4win

ramason's Avatar


06 Mar, 2021 03:24 PM

Using Gpg4win-3.1.15 1. I generate a key pair using Kleopatra vGpg4win-3.1.15
2. I share the public key with our vendor (Workday) so that they can encrypt files before being transmitted to our sFTP
3. Vendor transmits files to sFTP
4. I download the files from the sFTP
5. Using Kleopatra vGpg4win-3.1.15 to decrypt the file, I get the following message:
"gpg: encrypted with 4096-bit RSA key, ID D09C5584556627BA, created 2021-03-03 "private info>" gpg: WARNING: message was not integrity protected
gpg: decryption forced to fail!
6. I've since created to gpg.conf file with the ignore MDC command which has allowed me to bypass the error but I'd like to understand if this needs to be resolved/configured on my side when generating the keys or on the vendor side when encrypting. Is it an option within the encryption interface they are using?

  1. Support Staff 1 Posted by Steve on 07 Mar, 2021 10:00 AM

    Steve's Avatar

    Hi ramason,

    this is the community support platform for all things GPG Suite (OpenPGP on macOS).

    For any questions regarding gpg4win, please see their website about obtaining support. There are various resources like mailing list as well as user forum.

    If you find a solution, it would be great if you could crosslink the Gpg4win thread, so other users running into a similar issue will quickly find the solution.


  2. Steve closed this discussion on 26 Mar, 2021 12:50 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac