MacGPG: SCM SPR332 V2 pinpad not working

Lukas's Avatar

Lukas

04 Mar, 2021 08:17 AM

Hey all,

my SCM SPR332 V2 reader pinpad doesn't work.

Which of our tools is giving you problems?

GPG Services. I think the problem is related to scdaemon.

Attach a screenshot of the version info for all installed components (how to: https://gpgtools.tenderapp.com/kb/faq/where-can-i-find-version-info...):

Added as an attachment.

Describe your problem. Add as much detail as possible.

The pinpad is dead. PIN entry only works from keyboard. Reader itself works. The pinpad is supported in Linux (Ubuntu 20.04). In Ubuntu it worked for me while bringing the subkeys to the card. So it should be related to GPG Suite.

I'm really not experienced in scdaemon logs but my debug log (level basic) shows this:

2021-03-04 07:59:21 scdaemon[17567] Version-2+ .....: yes
2021-03-04 07:59:21 scdaemon[17567] Extcap-v3 ......: yes
2021-03-04 07:59:21 scdaemon[17567] Button .........: no
2021-03-04 07:59:21 scdaemon[17567] SM-Support .....: no
2021-03-04 07:59:21 scdaemon[17567] Get-Challenge ..: yes (2048 bytes max)
2021-03-04 07:59:21 scdaemon[17567] Key-Import .....: yes
2021-03-04 07:59:21 scdaemon[17567] Change-Force-PW1: yes
2021-03-04 07:59:21 scdaemon[17567] Private-DOs ....: yes
2021-03-04 07:59:21 scdaemon[17567] Algo-Attr-Change: yes
2021-03-04 07:59:21 scdaemon[17567] Symmetric Crypto: yes
2021-03-04 07:59:21 scdaemon[17567] KDF-Support ....: yes
2021-03-04 07:59:21 scdaemon[17567] Max-Cert3-Len ..: 2048
2021-03-04 07:59:21 scdaemon[17567] PIN-Block-2 ....: no
2021-03-04 07:59:21 scdaemon[17567] MSE-Support ....: yes
2021-03-04 07:59:21 scdaemon[17567] Max-Special-DOs : 2048
2021-03-04 07:59:21 scdaemon[17567] Cmd-Chaining ...: no
2021-03-04 07:59:21 scdaemon[17567] Ext-Lc-Le ......: yes
2021-03-04 07:59:21 scdaemon[17567] Status-Indicator: 05
2021-03-04 07:59:21 scdaemon[17567] GnuPG-No-Sync ..: no
2021-03-04 07:59:21 scdaemon[17567] GnuPG-Def-PW2 ..: no

For me this looks like a capability list. Button and PIN-Block-2 looks strange for me. Like scdaemon didn't recognizes the pinpad. But this could be totally worng. Driver of the reader is installed in macOS.

Pleas tell me how I can help further.

What did you expect instead

Working pinpad entry. Also working pinentry program output (like: Type PIN on reader pinpad).

Describe steps leading to the problem.

Simply normal workflow e.g. pin verify in gpg --edit-card.

Are you using any other Mail.app plugins?

No

  1. Support Staff 1 Posted by Steve on 04 Mar, 2021 09:39 AM

    Steve's Avatar

    Hi Lukas,

    welcome to the GPGTools support platform. Sorry you are having problems using GPG Suite.

    Has this setup previously worked on macOS or is this a first time setup?

    Could you please download and install our latest hotfix GPG Suite and see if that changes anything.

    All the best,
    Steve

    Disclaimer: Hotfixes are GPG Suite builds containing our latest source code, so bugs and crashes may occur.

  2. 2 Posted by Lukas on 04 Mar, 2021 10:11 AM

    Lukas's Avatar

    Hi Steve,

    same as in stable.

    Switch by Homebrew:

    brew uninstall --cask gpg-suite
    brew install --cask gpg-suite-nightly
    ... reboot

    Version info is attached.

    Best Regards

  3. 3 Posted by Lukas on 04 Mar, 2021 10:35 AM

    Lukas's Avatar

    I forgot to mention the other things:

    1. The installation is older. But updated always.
    2. The SCM SPR332 V2 reader is new and used the first time.
    3. The pinpad of my KOBIL KAAN Advanced workes. But this reader is really old and heavy used. The pinpad of my Reiner SCT cyberJack RFID komfort also don't work. Pinpad of KOBIL also works on Linux like the SCM SPR. cyberJack pinpad don't work on Linux and macOS.

    Best Regards

  4. 4 Posted by Lukas on 09 Mar, 2021 06:26 PM

    Lukas's Avatar

    Fun fact:

    The SCM SPR332 V2 is detected as SCM SPR 532. For the SPR 332 V2 pinpad is dead. SPR532 isn't detected. Just a device string number shown in gpg --card-status. Pinpad is broken. By a long PIN (SPR532 supports variable length) it stops after 7 entered keys in a way that it breaks or sends the stuff. It seems like a break because the PIN fail counter doesn't change and there is no worng PIN message. So everything fails. It's really buggy when it comes to smartcards. SPR332 V2 works with keyboard based pin entry.

    Best Regards

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Already uploaded files

  • gpgtools-versions.png 790 KB

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac