KeyMapping doesn't work

Igor's Avatar


07 Dec, 2020 03:46 PM

Which of our tools is giving you problems?

I had a key mapping configured like this

But in the latest update this seems to be broken. When I select a person which should be mapped, the Encrypt button is not active.

Attach a screenshot of the version info for all installed components (how to:

Describe your problem. Add as much detail as possible.

What did you expect instead

Describe steps leading to the problem.

Are you using any other plugins?


  1. 1 Posted by Igor on 07 Dec, 2020 03:56 PM

    Igor's Avatar

    How can I rollback to the previous GPGSuite release where it was working properly?

  2. Support Staff 2 Posted by Luke Le on 07 Dec, 2020 07:58 PM

    Luke Le's Avatar

    Hi Igor,

    thank you very much for bringing this issue to our attention.
    We have found that the regular expression was not properly build in V5, so it didn't match the appropriate keys.

    The good news is, that we have a hotfix GPG Suite that includes a fix for this issue.
    It would be great if you could test that.

    Please find download and install the hotfix from

    Disclaimer: Hotfixes are GPG Suite builds containing our latest source code, so bugs and crashes may occur.

  3. 3 Posted by Igor on 07 Dec, 2020 08:10 PM

    Igor's Avatar

    Thanks for your support. Yes, I can confirm that after installing the hotfix the issue has disappeared and now it works as supposed.

  4. Support Staff 4 Posted by Steve on 07 Dec, 2020 09:06 PM

    Steve's Avatar

    Glad this is solved for you. I'm closing this discussion. Should you need further assistance or have questions you can re-open this discussion here or open a new one any time.


  5. Steve closed this discussion on 07 Dec, 2020 09:06 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac