GPGTools for Mac OSX 10.5.8

Ted's Avatar

Ted

20 Aug, 2013 05:41 PM

What version should I be running on Mac 10.5.8?

(and no I cannot upgrade OS).

Thank you

  1. Support Staff 1 Posted by Luke Le on 20 Aug, 2013 05:49 PM

    Luke Le's Avatar

    Hi Ted,

    I'll post you the links to the versions I believe are still compatible with 10.5.8.
    Unfortunately it might require a little work to get them setup.

    GPGMail:
    https://github.com/downloads/GPGTools/GPGMail/GPGMail-1.2.0-10.5.dmg

    MacGPG 2.0.19 (for intel only)
    https://s3.amazonaws.com/gpgtools/MacGPG2-2.0.19.dmg
    or for PPC
    https://github.com/downloads/GPGTools/MacGPG2/MacGPG2-2.0.16.zip

    GPG Keychain Access:
    https://github.com/downloads/GPGTools/GPGKeychainAccess/GPG%20Keych...

    Hope this helps.

  2. 2 Posted by Ted on 21 Aug, 2013 04:15 AM

    Ted's Avatar

    Thank you.

    I was able to successfully install all three (MacGPG for PPC worked and MacGPG for Intel only didn't, even though this machine is running an Intel proc).

    Now I will see if I can get them to work.

    Thanks again.

  3. Support Staff 3 Posted by Luke Le on 21 Aug, 2013 08:53 PM

    Luke Le's Avatar

    Glad to hear that.

    Closing this discussion in the meantime. You can always re-open it if you have further questions or run into problems.

  4. Luke Le closed this discussion on 21 Aug, 2013 08:53 PM.

  5. Steve re-opened this discussion on 22 Aug, 2013 02:50 PM

  6. Support Staff 4 Posted by Steve on 22 Aug, 2013 02:53 PM

    Steve's Avatar

    Hey Ted,

    very strange that you were unable to re-open this discussion. Discussions can be re-opened by the original poster. Hmm.

    Posting your reply here so we have everything in one spot:

    TED WROTE:

    Luke helped me and I was able to install these three programs successfully:

    GPGMail:
    https://github.com/downloads/GPGTools/GPGMail/GPGMail-1.2.0-10.5.dmg

    MacGPG 2.0.19
    https://github.com/downloads/GPGTools/MacGPG2/MacGPG2-2.0.16.zip

    GPG Keychain Access:
    https://github.com/downloads/GPGTools/GPGKeychainAccess/GPG%20Keych...

    I was able to use GPG Keychain Access to create a new key, save it, open it as a .txt file and see the public key.

    What I cannot figure out how to do is import someone else's public key and encrypt a message back to them. Importing a .txt file into Keychain access does not seem to be an option.

    Can you tell me how to import someone else's public key? And how to use it to encrypt a message they can receive?

    I tried to re-open my original discussion, but couldn't figure it out.

    Thank you.

  7. Support Staff 5 Posted by Steve on 22 Aug, 2013 02:57 PM

    Steve's Avatar

    The problem is, the entire team is on 10.8. We don't have any 10,5 testing system.

    I can't even remember what the software looked back on 10.5. If you want you can send a screenshot of what you are seeing.

    Isn't there any import option? Maybe you need the pub key in .asc file format and then can import that file via GPG Keychain Access? Try renaming your .txt file and re-try. Also there could already be some key server options. Did you try those?

    best, steve

  8. 6 Posted by Ted on 23 Aug, 2013 03:47 AM

    Ted's Avatar

    Thanks Steve,

    Sorry for the hassle - if this is not supported I totally understand.

    I did save a public key example and change the extension to .asc, this did allow GPG Keychain Access to recognize and attempt to import the file.

    However, the import never completes and I get the error pictured [1].

    If I can get that figured out, I still can't figure out how to encrypt text. Mail now gives me these PGP options pictured [2], and TextEdit these [3].

    However, when I highlight text in TextEdit and choose >Encrypt or >Encrypt & Sign the text un-highlights but remains unchanged.

  9. Support Staff 7 Posted by Luke Le on 24 Aug, 2013 08:30 PM

    Luke Le's Avatar

    Hi Ted,

    if you could send us the public key, we could try to determine why it's not importing.

    As for the TextEdit problem, if I can find a 10.5.8 installation, I'll try to reproduce the error, but that could take some time. Sorry.

  10. 8 Posted by Ted on 25 Aug, 2013 05:34 PM

    Ted's Avatar

    Public Key attached.

    If there's any more info I can provide to help please let me know.

    Thank you.

  11. Support Staff 9 Posted by Steve on 25 Aug, 2013 06:18 PM

    Steve's Avatar

    Hi Ted,

    well I can import the key from http://s3.amazonaws.com/entp-tender-production/assets/171a3d3d07526... just fine.

    Did you try visiting that URL select cmd + a, then cmd + c.

    Then open GPG Keychain Access and hit cmd + v

    Does that do anything?

  12. 10 Posted by Ted on 25 Aug, 2013 11:25 PM

    Ted's Avatar

    Hi Steve,

    After visiting the URL cmd + a then cmd +v in GPG Keychain Access. I get the same result as photo [1].

  13. 11 Posted by Ted on 26 Aug, 2013 04:17 PM

    Ted's Avatar

    Hi All,

    Is it possible the original link above from Luke for MacGPG 2.0.19 (for intel only) is incorrect?

    This software requires Mac OSX 10.6 or above and my hardware limits me to Mac OSX 10.5.8. I am runnint the Intel processor.

    The PPC link did appear to install correctly.

    Thank you.

  14. Support Staff 12 Posted by Steve on 26 Aug, 2013 06:06 PM

    Steve's Avatar

    Ted, I'm not sure, if MacGPG did not install on your system changes are this is why GPG Keychain Access is not working.

    Please find MacGPG2 2.0.16 here: http://old.gpgtools.org/macgpg2/index.html
    or via direct link: https://github.com/downloads/GPGTools/MacGPG2/MacGPG2-2.0.16.zip

    Does that improve the situation?

  15. 13 Posted by Ted on 27 Aug, 2013 02:56 AM

    Ted's Avatar

    Thanks Steve,

    Unistalled everything then installed 2.0.16 and am getting the same results as originally pictured above.

  16. 14 Posted by Ted on 27 Aug, 2013 05:01 AM

    Ted's Avatar

    OK, I think I am able to generate a PGP message using Mail and sending an email to myself.

    I still can't import a public key to GPG Keychain Access. Getting the same error pictured in [1] above.

  17. Support Staff 15 Posted by Steve on 27 Aug, 2013 08:10 AM

    Steve's Avatar

    Two solutions, otherwise I feel we're out of luck since that very old GPG Keychain Access won't receive any patches.

    • open Terminal

    First, if you do already have the key on your harddrive:

    • gpg --import path/to/key

    If you want to import the key from the key servers via Terminal:

    • gpg --search-key EmailAddress

    Does that work?

  18. 16 Posted by Ted on 28 Aug, 2013 12:22 AM

    Ted's Avatar

    I'm not sure I'm using the correct Terminal commands (I have never used Terminal before). I get this response from your first suggestion:

    gpg [options] [filename]

    Can you please be more explicit as far as exactly what characters I actually type into terminal?

    Thank you.

    Ted

  19. 17 Posted by Ted on 28 Aug, 2013 04:57 AM

    Ted's Avatar

    Neveer mind - I think I figured it out. I think it works! I got this result in terminal:

    gpg: key 5072E1F5: public key "MySQL Release Engineering <[email blocked]>" imported
    gpg: Total number processed: 1
    gpg: imported: 1
    gpg: 3 marginal(s) needed, 1 complete(s) needed, PGP trust model
    gpg: depth: 0 valid: 1 signed: 0 trust: 0-, 0q, 0n, 0m, 0f, 1u

    and I'm seeing a new key in GPG Keychain Access.

  20. Support Staff 18 Posted by Steve on 01 Sep, 2013 08:53 PM

    Steve's Avatar

    HA! :)

    That is great. Not user friendly but it is what you wanted to do. Glad this worked.

    So were you able to send an encrypted mail as well? You really need to get a newer machine. So you can enjoy the ease of GPGMail 2. ;)

    Btw, pardon my curiosity, are you working with Ted? Just noticed your mail address...

    Best, steve

  21. Steve closed this discussion on 18 Sep, 2013 03:07 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac