GPG Keychain: Pass phrase rejected

p.millson's Avatar


23 Aug, 2020 11:06 AM

I tried to import a public key this morning and was asked for my pass phrase. This hasn’t happened before. Then when I copied my pass phrase from where is is stored in a secure note it Mac keychain, it was rejected twice, so I stopped. Can you help please?

I expected to be able to import the key. Then I expected my pass phrase to work when asked for it.

macOS                   10.15.5     19F101
GPG Suite               2019.1      2539    (f7527f7dd4)
GPG Mail    -
GPG Keychain            1.5         1577    (6daf90a76b)
GPG Services            1.12        1096    (17b325bb15)
MacGPG                  2.2.17      938     (cb13729b0b)
GPG Suite Preferences   2.2         1115    (f813be50a8)
Libmacgpg               1.0         920     (b50a3b4b50)
pinentry           14      (c191c4128d)
  1. Support Staff 1 Posted by Steve on 23 Aug, 2020 02:42 PM

    Steve's Avatar

    Hi p.millson,

    welcome to the GPGTools support platform. Sorry you are having problems using GPG Suite.

    You are using an old version of GPG Suite. Please download and install the current stable version which is GPG Suite 2020.1. To receive update notifications you can enable automatic updates in System Preferences > GPG Suite Preferences > Settings > Update.

    As for your import problem: Are you certain this is only a public key? Importing a public key will not ask for a passphrase. So you might be trying to import a secret key. You can open the file you are trying to import in a text editor and search for "private key". Do you see that string?

    If this is a secret key from a third party, your passphrase will not work which would be expected. But you should inform that third party that they are sharing their secret key, which never should be done. So they should probably revoke that key and create a new key.

    All the best,

  2. 2 Posted by p.millson on 23 Aug, 2020 03:32 PM

    p.millson's Avatar

    Gosh you’re absolutely right, they have sent me their private key by mistake. I’ll let them know.

    I will update as you suggest.

    Many thanks for your prompt reply. Much appreciated.

    All best to you


  3. Support Staff 3 Posted by Steve on 24 Aug, 2020 09:36 AM

    Steve's Avatar

    Glad this is solved for you. I'm closing this discussion. Should you need further assistance or have questions you can re-open this discussion here or open a new one any time.


  4. Steve closed this discussion on 24 Aug, 2020 09:36 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac