GPG Mail: Can't enable mail plugin

Kirill A. Korinsky's Avatar

Kirill A. Korinsky

10 Aug, 2020 04:55 PM

Good day!

I'm using:
- macOS version 10.15.6 (19G73) - mail app version 13.4 (3608.120.23.2.1)

I can't enable a plugin at all. When I select to enable it on attached screenshot and click restart mail app is nothing happened.

What should I do?

This discussion was closed! See this FAQ for more information:

  1. Enable GPG Mail on macOS Mojave or newer

    On macOS Mojave or newer you need to enable the plug-in after installation. To enable GPG Mail please

    • open Mail > Preferences > General > Manage Plug-Ins…
    • tick checkbox for GPGMailLoader.mailbundle
    • confirm with "Apply and Restart Mail"

    After the restart GPG Mail will be loaded and Mail > Preferences > GPG Mail will show.

    GPG_Mail_enable_macOS_10.14_Mojave.png

    See more..
  1. 1 Posted by Kirill A. Korin... on 10 Aug, 2020 06:57 PM

    Kirill A. Korinsky's Avatar

    After the restart GPG Mail will be loaded and Mail > Preferences > GPG Mail will show.

    At my case after restart of mail app nothing happens, and this checkbox inside plugins is uncheked.

    I've tried it a lot of times.

  2. Support Staff 2 Posted by Steve on 11 Aug, 2020 05:54 PM

    Steve's Avatar

    Hi Kirill,

    welcome to the GPGTools support platform. Sorry you are having problems using GPG Suite.

    Can you double check, you have the latest GPG Suite installed on your system. Currently that is GPG Suite 2020.1.

    Then you should see a second mailbundle file and tick that and that should bring you to working state.

    Let me know if this worked.

    Best,
    Steve

  3. 3 Posted by Kirill A. Korin... on 11 Aug, 2020 05:57 PM

    Kirill A. Korinsky's Avatar

    I guess I have the latest version. Anyway, I've attached a screenshot.

    It was a second, but I also tried to:
    - reinstall GPG Tools; - uninstall GPG tools and install it again.

    Nothing helps.

    I've tried to find any trace of debug log or error, but nothing related to GPGTools is appears in Console app.

  4. Support Staff 4 Posted by Steve on 11 Aug, 2020 06:01 PM

    Steve's Avatar

    This sounds like a bug in macOS Mojave/Catalina which sometimes prevents plugins from loading due to faulty permissions.

    In order to fix that, please follow these steps:

    The solution is to enable Full Disk Access and after that running a Terminal command.

    Steps:

    1. Close Mail.app
    2. Open System Preferences › Security › Privacy
    3. Enable Terminal under Full Disk Access
    4. Restart Terminal when prompted
    5. Run the following command:

      rm -rf ~/Library/Containers/com.apple.mail/Data/DataVaults

    6. Open Mail

    If that doesn’t help, you will have to disable SIP and run step 5 again.
    https://gpgtools.tenderapp.com/kb/how-to/temporarily-disable-macos-...

    Hope that helps.

  5. 5 Posted by Kirill A. Korin... on 11 Aug, 2020 07:30 PM

    Kirill A. Korinsky's Avatar

    Steve, before I remove DataVaults can I ask you which information contains inside this file and that will be lost?

  6. Support Staff 6 Posted by Luke Le on 11 Aug, 2020 09:12 PM

    Luke Le's Avatar

    Hi Kirill,

    this folder contains the enabled mail bundles. Whenever you enable a mail bundle via Mail › Preferences › General › Manage Plug-ins… it is copied by Mail into the DataVaults folder. The DataVaults folder can't be modified without SIP being disabled or the process trying to access it having special entitlements (as Mail does). In your case it appears that the DataVaults folder has the wrong permissions. That is the reason why not even Mail can copy the mail bundle into the folder.

    The steps outlined by Steve will remove the folder which allows Mail to re-create it with the appropriate permissions, making sure it always has write access to it.

    Hope that explains what is going on.

  7. 7 Posted by Kirill A. Korin... on 12 Aug, 2020 09:37 PM

    Kirill A. Korinsky's Avatar

    I'd like to confirm that removing this folder fixed an issue.

  8. Support Staff 8 Posted by Steve on 17 Aug, 2020 01:09 PM

    Steve's Avatar

    Glad this is solved for you. I'm closing this discussion. Should you need further assistance or have questions you can re-open this discussion here or open a new one any time.

    Best,
    Steve

  9. Steve closed this discussion on 17 Aug, 2020 01:09 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac