GPG Mail: Not showing up in Mail.app

Michael Horwath's Avatar

Michael Horwath

30 Jul, 2020 03:01 PM

I have installed GPG Suite on my laptop and I do not see anything in mail preferences and I do not think it is loading.

Of course this works on my workstation.

Expected
Expecting it to work

Additional info
I am a license holder.

macOS                   10.15.5     19F101
GPG Suite               2020.1      2787    (c9e4d273d9)
GPG Mail (enabled)      4.1         1530    (ad7b466590)    Decrypt Only Mode
GPG Keychain            1.6         1619    (d9f323fe3e)
GPG Services            2.0         1116    (0e712c951c)
MacGPG                  2.2.20      943     (a8c05a09fc)
GPG Suite Preferences   2.3         1147    (3676fecd1d)
Libmacgpg               1.1         927     (c29e5dab99)
pinentry                1.1.0.3     17      (85b3564ea3)
  1. Support Staff 1 Posted by Steve on 30 Jul, 2020 03:15 PM

    Steve's Avatar

    Hey Michael,

    thanks for reaching out. Sorry you are having problems using GPG Suite.

    If you are using macOS Mojave or Catalina and can‘t find any signs of GPG Mail: Apple disables any installed plugins after installation and they have to be enabled manually.

    Or did you try that already but GPG Mail keeps disappearing?

    Best,
    Steve

  2. 2 Posted by Michael Horwath on 01 Aug, 2020 12:43 PM

    Michael Horwath's Avatar

    I did a find across the filesystem for the bundle and removed things, and reinstalled.

    Here are screenshots.

  3. Support Staff 3 Posted by Steve on 01 Aug, 2020 02:06 PM

    Steve's Avatar

    We apologize for the bad experience. What you describe is unrelated to any issues with your support plan, but rather a bug in macOS Mojave/Catalina which sometimes prevents plugins from loading due to faulty permissions.

    In order to fix that, please follow these steps:

    The solution is to enable Full Disk Access and after that running a Terminal command.

    Steps:

    1. Close Mail.app
    2. Open System Preferences › Security › Privacy
    3. Enable Terminal under Full Disk Access
    4. Restart Terminal when prompted
    5. Run the following command:

      rm -rf ~/Library/Containers/com.apple.mail/Data/DataVaults

    6. Open Mail

    If that doesn’t help, you will have to disable SIP and run step 5 again.
    https://gpgtools.tenderapp.com/kb/how-to/temporarily-disable-macos-...

    Please let me know if that brings you back to working state.

  4. Steve closed this discussion on 11 Aug, 2020 09:56 PM.

  5. Steve re-opened this discussion on 11 Aug, 2020 09:56 PM

  6. Support Staff 4 Posted by Steve on 11 Aug, 2020 09:56 PM

    Steve's Avatar

    Closing, since no further user feedback was received. Should your problem persist, feel free to re-open this discussion any time.

    All the best,
    Steve

  7. Steve closed this discussion on 11 Aug, 2020 09:56 PM.

  8. Mike Horwath re-opened this discussion on 11 Aug, 2020 10:01 PM

  9. 5 Posted by Mike Horwath on 11 Aug, 2020 10:01 PM

    Mike Horwath's Avatar

    Thanks, still battling permissions but it isn't an issue you need to be involved with

  10. Support Staff 6 Posted by Steve on 11 Aug, 2020 10:01 PM

    Steve's Avatar

    Did you try the steps outlined here?

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac