GPG Mail: Messages are truncated

Mark Nottingham's Avatar

Mark Nottingham

06 Dec, 2019 10:54 PM

With the most recent update to Stable, encrypted / signed messages are truncated.

In the Message Viewer, only the "wrapper" that says "Signed PGP Part" and the first line of the message is visible, no matter how long the message is. No scrollbar is available.

If opened as a new window, more is visible, but there is still no scrollbar, so if the message is longer than the available screen height, some content is not accessible.

To be able to view my encrypted / signed messages in the same way as other e-mails.

macOS                   10.15.1     19B88
GPG Suite               2019.2      2670    (ac945f92b0)
GPG Mail                4.0         1515    (597c8f5250)    19 trial days remaining
GPG Keychain            1.5.1       1587    (967419866a)
GPG Services            1.12.1      1100    (2d6c8340f0)
MacGPG                  2.2.17      940     (4ba83bbeda)
GPG Suite Preferences   2.2.1       1136    (378dbebf37)
Libmacgpg               1.0.1       924     (ed76f66a8a)
pinentry           16      (9b8e20e2c0)
  1. Support Staff 1 Posted by Steve on 06 Dec, 2019 11:21 PM

    Steve's Avatar

    Hi Mark,

    thanks for taking the time to report this problem and sorry for the troubles.

    We have a ticket for this problem. I connected this discussion with the existing ticket. That means, should this discussion get closed, it will be re-opened as soon as the ticket is closed. That way you'll stay in the loop and get notified as soon as we have news. Feel free to open a new discussions should you run into further problems or need assistance.


  2. 2 Posted by Sander Steffann on 30 Dec, 2019 09:55 PM

    Sander Steffann's Avatar

    I have the same problem. It's the biggest usability problem I have with GPG Mail at the moment, Everything else seems to work great, but having to open messages in separate windows to be able to read them is annoying.

  3. 3 Posted by Igor on 31 Dec, 2019 04:01 PM

    Igor's Avatar

    I'm having the same problem, most of the encrypted messages are truncated. Do you know when can we expect the fix for this problem? It's very annoying and I just bought the support plan.

  4. 4 Posted by Sazhen86 on 31 Dec, 2019 07:25 PM

    Sazhen86's Avatar

    Adding my voice to the crowd. This makes GPG mail unusable for long messages. Opening in another window doesn't help if the content is longer than the screen allows.

  5. Support Staff 5 Posted by Steve on 09 Jan, 2020 10:33 PM

    Steve's Avatar

    Hi all,

    thanks for chiming in.

    This is sadly still unfixed. Just wanted to share a simple workaround: you can simply forward the partly signed message and read it in the new draft window and close the draft when done.

    Obviously not beautiful but at least you can make sure you are able to access the messages in question completely.

    I upped the priority of the open bug as this affects a few of our users.


  6. 6 Posted by Jacob on 14 Jan, 2020 09:01 PM

    Jacob's Avatar

    I have the same problem but for non-encrypted with a digital signature messages. I can only see what is available because of screen height. The scrollbar is missing. Is this the same error or a different problem? It is definitely related to the plugin because it comes and goes with deactivating it.

  7. Support Staff 7 Posted by Steve on 14 Jan, 2020 11:28 PM

    Steve's Avatar

    Jacob, yes it is.

    For the meantime see comment #5 for a workaround.

  8. Steve closed this discussion on 20 Jan, 2020 07:04 PM.

  9. Support Staff 8 Posted by Steve on 08 Jun, 2020 08:42 PM

    Steve's Avatar

    Hi all,

    GPG Suite 2020.1 is now available and the issue, that partly signed messages can not be scrolled, is fixed.

    All the best,

  10. Steve closed this discussion on 08 Jun, 2020 08:42 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac