10.8.4: GPGServices (Operation cancelled) Error code = 99

Flavio's Avatar

Flavio

03 Aug, 2013 02:50 PM

Hi,

I've upgraded to the latest version of GPG suite few minutes ago.
When I try to encrypt a file sometimes it fails.
When I try to decrypt a file always fails with the Error code =99.

Any suggestion? Probably did I wrong the installation or did I miss something?

Thx,

Flavio

  1. 1 Posted by Flavio on 03 Aug, 2013 05:01 PM

    Flavio's Avatar

    I've forgot to mention that I'm using OSX 10.8.4. I've tried also to uninstall and install again. Same error code when I try to decrypt.
    Also it does not ask for the passphrase to decode, the error appears immediately.
    I can see it tries to create a .tmp file just before returning the error 99.
    Hope this can help.

  2. 2 Posted by Flavio on 05 Aug, 2013 06:11 AM

    Flavio's Avatar

    Hi,

    I tried to use the GPG command line instead of GPG services to get more info about the problem.

    Here is the result.

    MacBook-Pro-di-Flavio-Muscetra:Downloads flavio$ gpg -d -r [email blocked] "_MG_4725 copy.psd.gpg" 
    
    You need a passphrase to unlock the secret key for
    user: "Flavio Muscetra <[email blocked]>"
    2048-bit ELG key, ID 47D52E50, created 2008-11-11 (main key ID 3A73EDE3)
    
    gpg: problem with the agent: No pinentry
    gpg: encrypted with 2048-bit ELG key, ID 47D52E50, created 2008-11-11
      "Flavio Muscetra <[email blocked]>"
    gpg: public key decryption failed: Operation cancelled
    gpg: decryption failed: No secret key
    MacBook-Pro-di-Flavio-Muscetra:Downloads flavio$
    
  3. 3 Posted by Flavio on 05 Aug, 2013 06:19 AM

    Flavio's Avatar

    After few more tests it seems that encryption works fine if files are encrypted with recipient public key. I've used my own public key to encrypt files for myself.

    Instead decryption of the same file, encrypted for myself ,does not work. It returns the same error as described in my first posting.

    I suspect the problem is with the passphrase used to decrypt.
    GPG services and GPG command line do not ask me to enter the passphrase and then the decryption fails.

  4. Support Staff 4 Posted by Steve on 05 Aug, 2013 03:44 PM

    Steve's Avatar

    Hi Flavio,

    thanks for taking the time to report this problem and sorry for the trouble.

    We hope to tackle this issue soon and will then update this discussion accordingly.

    We've a ticket for this problem:

    https://gpgtools.lighthouseapp.com/projects/65162/tickets/164-pinen...

    Should this discussion get closed, it will be re-opened as soon as the ticket is closed so you'll receive a notification. Feel free to open a new discussions should you run into further problems or need assistance.

  5. Support Staff 5 Posted by Steve on 06 Aug, 2013 10:04 AM

    Steve's Avatar

    Hi Flavio,

    we have a new GPG Suite ready that should fix this problem.

    Please download https://s3.amazonaws.com/gpgtools/GPG%20Suite%20-%202013.08.06.dmg then mount the .dmg file and run the Install.

    Let us know if things run smoothly with that version. Looking forward to your feedback.

    Best :)
    steve

  6. 6 Posted by Flavio on 06 Aug, 2013 10:38 AM

    Flavio's Avatar

    Hi Steve,

    This morning I've tried the suggestion in ticket #164

        The workaround is to either always replace the path with Libmacgpg pinentry-path or MacGPG2 pinentry-path,
        or have a post script for the installer itself, which fixes the path.

    I've replaced the gpg-agent.conf pinentry-path with the MacGPG2 pinentry-path and it seems it works.
    I had to run out to the office so I didn't do many tests and I would like to test it more tonight before confirming that all is ok.

    In the worst case I will install the new GPG suite.

    Thx a lot!

    Flavio

  7. Support Staff 7 Posted by Steve on 06 Aug, 2013 10:39 AM

    Steve's Avatar

    Sounds good. Please keep us posted.

  8. 8 Posted by Flavio Muscetra on 07 Aug, 2013 05:38 AM

    Flavio Muscetra's Avatar

    I did some more tests and I think now i can say that GPG suite works fine for me.
    I can encrypt and decrypt files on my HD.
    I can sign, and encrypt emails, however I cannot check if I can decrypt emails as nobody sent me an encrypted email using my public key.

    I think I can say that we can close this case.

    Thanks again.

    Flavio

  9. Support Staff 9 Posted by Steve on 07 Aug, 2013 09:58 AM

    Steve's Avatar

    Flavio, that is great news. Glad, this is solved for you. I'm closing this discussion. If you need further assistance or have questions open a new discussion any time.

    Best, steve

  10. Steve closed this discussion on 07 Aug, 2013 09:58 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac