Installation - Gpg Preferences/Services

asyidion's Avatar


09 Mar, 2012 07:36 AM

Attempted to download GPG Tools and had a problem trying to encrypt text. I couldn't find the GPG option under services (keyboard preferences), so I tried installing GPG Services and GPG Preferences individually. Gpg Preferences ran into error that said something along the lines of "couldn't access preferences pane". I uninstalled everything, tried to reinstall GPG tools, but I am still only seeing the Keychain Access application. Am I making a mistake somewhere?


  1. Support Staff 1 Posted by Steve on 10 Mar, 2012 07:42 AM

    Steve's Avatar

    Hi Asyidion,

    since I'm not sure which versions of our tools you are running, I'd suggest you try out our latest nightly build from here:

    Please run the GPGTools Installer, once the dmg is mounted you'll see an uninstaller as well. Run that first. Then re-install.

    Let us know if then GPGServices shows up correctly. Also see to make sure you understand where to activate the services.

    All the best, steve

  2. 2 Posted by asyidion on 10 Mar, 2012 08:36 AM

    's Avatar

    Hi Steve,

    I am using OS X 10.8. Your suggestion is what I ended up trying to do several times, using both builds. I tried it once more a few minutes ago and still no success it seems. Gpg Mail, Services, Preferences don't seem to be installing. The attempt to uninstall showed this message, "no receipt for 'org.gpgtools.' found at '/' ", although the uninstall did work several times before last (??). The installation error read, "run postinstall script GPGMail - 105". I am pretty lost as to what could be going on. Once installed, these are the items I see: GPG keychain access; GPGTools_Installer; GPGTools (Volume); and GPGTools.mpkg (installer pack).

  3. 3 Posted by Benjamin Albers on 11 Mar, 2012 11:23 AM

    Benjamin Albers's Avatar

    I have the same problem.
    Installed GPGTools successfully. Email encryption in is working fine.
    I cannot use the services from within TextEdit though. All services are activated in System Preferences, but they do not appear in the services menu in TextEdit.

    In the services show up, but nothing happens I try to encrypt text directly in an email message.

    Many thanks.

  4. 4 Posted by cfraire on 11 Mar, 2012 08:35 PM

    cfraire's Avatar

    GPGServices works with both "Files and Folders" and with "Text". You will see these categories in the Services preferences (System Preferences > Keyboard > Keyboard Shortcuts > Services). (see screenshot)

    When you install GPGServices, the OpenPGP "Files & Folders" items will be automatically selected, but the OpenPGP "Text" items will not be. Please make sure you scroll to see both sections of OpenPGP items, and activate all you wish.

  5. 5 Posted by Benjamin Albers on 11 Mar, 2012 09:06 PM

    Benjamin Albers's Avatar

    All GPGServices are selected. In other applications they do appear properly in the Services Menu, such as in Microsoft Word, but when I select text and try to encrypt it, the window appears asking me to select a certificate for encryption, but when I select it and click OK, nothing happens. (see attached).

    The Certificate is definitely working, as I have successfully sent encrypted emails from within It is just the services that seem not to be working.

    I am using MacOSX 10.7.3 with all latest updates installed. I have also tried reinstalling GPGTools and restarting my computer.

    Thanks for the help!

    I have attached screenshots showing this.

  6. 6 Posted by cfraire on 11 Mar, 2012 11:02 PM

    cfraire's Avatar

    Benjamin, would you try the nightly version of GPGServices which Steve mentions above at That version expands the description of the OpenPGP services in the context menu, which might help determine why it's active in other applications but not TextEdit.

    After installing, please would you check again the selected services in Keyboard preferences; conduct your experiment again; and reply with screen shots of the context menu in the other applications.

  7. 7 Posted by Benjamin on 12 Mar, 2012 06:14 PM

    Benjamin's Avatar

    I tried just updating to the nightly version of GPGServices. No change. I then uninstalled completely and reinstalled the entire package of the nightly version.
    Unfortunately still no change. Screenshots are attached.

  8. 8 Posted by cfraire on 13 Mar, 2012 08:39 PM

    cfraire's Avatar

    Hello. Please would you try again the nightly build of GPGServices ( and report your results. It contains an update so the services work properly in Microsoft Word.

  9. 9 Posted by Benjamin Albers on 13 Mar, 2012 09:09 PM

    Benjamin Albers's Avatar

    After installing the latest nightly build of GPGServices, encryption in MS Word now seems to be working fine, thanks for that!
    Decrypting the encrypted text however, does not. The encrypted text remains unaffected. An error message appears as a growl pop-up -
    "Decrypt failed! Code = 0".

    Also, the relevant services are still now showing up in TextEdit.

  10. 10 Posted by cfraire on 14 Mar, 2012 12:44 AM

    cfraire's Avatar

    Asydion, these are the steps to install:

    1. Download the GPGTools Installer disk image (.dmg)
    2. Double-click the disk image to open the volume and reveal GPGTools.mpkg
    3. Double-click GPGTools.mpkg to start the installer, and run it to completion
  11. 11 Posted by Alex on 17 Mar, 2012 02:17 PM

    Alex's Avatar

    This discussion is now a mixture of a request from asydion and from Benjamin. Please create a new discussion if there are open issues. Thanks a lot,

  12. Alex closed this discussion on 17 Mar, 2012 02:17 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac