GPG Mail: Mac Mail crashes when composing email

Cecil Claspell's Avatar

Cecil Claspell

23 Aug, 2019 02:03 PM

Added the GPGMail add-in to Mac Mail, then clicked the compose email button. The mail application shutdown without warning.

Email created and sent with GPG encryption

macOS                   10.14.4     18E227
GPG Suite               2019.1      2529    (f7527f7dd4)
GPG Mail                3.2         1378    (8bf46a6372)    30 trial days remaining
GPG Keychain            1.5         1577    (6daf90a76b)
GPG Services            1.12        1096    (17b325bb15)
MacGPG                  2.2.17      938     (cb13729b0b)
GPG Suite Preferences   2.2         1115    (f813be50a8)
Libmacgpg               1.0         920     (b50a3b4b50)
pinentry           14      (c191c4128d)
  1. Support Staff 1 Posted by Steve on 23 Aug, 2019 02:47 PM

    Steve's Avatar

    Hi Cecil,

    welcome to the GPGTools support platform. Sorry you are having problems using GPG Suite.

    We are unable to reproduce this specific problem on our macs, which makes debugging and fixing this problem somewhat difficult.

    Would you be willing to have a remote debugging session?

    You would have to temporarily disable SIP System Integrity Protection (SIP) and install Xcode on your mac.

    a) temporarily disable SIP

    1. Click the  menu.
    2. Select Restart...
    3. Hold down command-R to boot into the Recovery System.
    4. Click the Utilities menu and select Terminal.
    5. Type csrutil disable and press return.
    6. Close the Terminal app.
    7. Click the  menu and select Restart....

    Once debugging is finished, please re-enable SIP. Repeat these steps, changing csrutil disable to csrutil enable instead.

    b) install Xcode

    Xcode is available via the Mac App Store:

    Looking forward to your feedback.

    All the best,

  2. 2 Posted by Cecil Claspell on 23 Aug, 2019 04:11 PM

    Cecil Claspell's Avatar

    Hi Steve,

    I have followed your instructions to disable SIP and install Xcode. A little more detail on the error: mail abruptly closes when I click the “OpenPGP” button in the menu bar and select S/Mime.



  3. Support Staff 3 Posted by Steve on 23 Aug, 2019 04:28 PM

    Steve's Avatar

    Hi Cecil,

    we are currently in a debug session with another user. So we will follow up with your case as soon as that is finished.

    Meanwhile, could you trigger the crash and send us the crash log? Copy the crash log info to a new TextEdit file and save that as .txt file. Then attach that file to your email reply to this discussion.

    We will then take a closer look as to what may be going wrong in your case.

    Could you double check macOS keychain if it has any expired S/MIME certs of yours and remove those. Also re-installing actively used S/MIME certs would be worth a try.

    When would it be possible for you to have a debug session?


  4. 4 Posted by Cecil Claspell on 23 Aug, 2019 04:44 PM

    Cecil Claspell's Avatar

    Crash log is attached.

    I have checked the macOS keychain and removed all my expired S/MIME certs. I am available between 1:30 PM and 4:30 PM Pacific time (UTC-7) today for debugging.



  5. 5 Posted by Cecil Claspell on 23 Aug, 2019 04:52 PM

    Cecil Claspell's Avatar

    Update: After removing all my expired S/MIME certs, I cannot reproduce
    the crash when switching from OpenPGP to S/MIME.


    Cecil Claspell
    Member Training Staff Officer
    US Coast Guard Auxiliary Flotilla 64
    Monterey, California
    831.206.5902 Cell

  6. Support Staff 6 Posted by Steve on 23 Aug, 2019 07:47 PM

    Steve's Avatar

    Glad this is solved for you. I'm closing this discussion. Should you need further assistance or have questions you can re-open this discussion here or open a new one any time.


  7. Steve closed this discussion on 23 Aug, 2019 07:47 PM.

  8. Steve closed this discussion on 09 Oct, 2019 09:52 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac