GPG Keychain: cannot decrypt some emails

brian simmons's Avatar

brian simmons

19 Aug, 2019 11:32 PM

Message:
None of the following secret keys could be found in your keychain (67783ACE). The secret key is needed to decrypt this message.
Problem: I see 67783ACE in my subkey menu with a 2022 expiration date, so I don’t understand why I can’t decrypt…

Expected
should decrypt

Additional info
none

Mac OS X        10.10.5             (14F2511)
Libmacgpg       0.7         769 
GPGMail         2.6.1       1151
GPG Keychain    1.3.1       1223
GPGServices     1.11        907 
MacGPG2         2.0.30      875 
GPGPreferences  2.0         887 
Pinentry        0.9.7       2
  1. Support Staff 1 Posted by Steve on 23 Aug, 2019 10:04 PM

    Steve's Avatar

    Hi Brian,

    welcome to the GPGTools support platform. Sorry you are having problems using GPG Suite.

    This indeed seems to be an odd case. Please note that GPG Suite required macOS 10.12 or later.

    The old version you are running is no longer support.

    Do you have any chance to update your mac to a newer OS?

    Could you check if your key has nonetheless expired? Check the key tab as well as the subkey tab.

    All the best,
    Steve

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Already uploaded files

  • 2019-08-19_23-32_DebugInfo.gpg 25.7 KB

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac