GPG Services: Fingerprint automatically pasted

Dimitris's Avatar


18 Jul, 2019 11:31 AM

After installing gpg keychain on the mac, the following probleam appeared:

everytime I press the shortcut cmd + shift + F (used for searching) on my IDE, the search box opens and my fingerprint is automatically pasted into the search input.

Does your software includes any kind of global shortcut for pasting the fingerprint?

Also, note that "Send Report" tab of GPG Suite on the mac shows up incorrectly when using dark mode: The letters in the inputs are colored in black which makes it impossible to read.

I wouldn't expect the fingerprint to show up.

macOS                   10.14.5     18F132
GPG Suite               2018.5      2368    (6f26711)
GPG Mail                3.0.1       1330    (807c323e)  30 trial days remaining
GPG Keychain            1.4.6       1514    (560b5a9)
GPG Services            1.11.6      1056    (ad0c960)
MacGPG                  2.2.10      921     (b487092)
GPG Suite Preferences   2.1.4       1077    (ad934a9)
Libmacgpg               0.8.7       895     (78f424a)
pinentry                1.1.0       10      (1ff8803)
  1. 1 Posted by Dimitris on 18 Jul, 2019 11:36 AM

    Dimitris's Avatar

    The fingerprint is pasted when typing the shortcute cmd + shift + F in a terminal window. So the issue doesn't seem to be related to the IDE.

  2. Support Staff 2 Posted by Steve on 18 Jul, 2019 08:14 PM

    Steve's Avatar

    Hi Dimitris,

    thanks for getting in touch about this problem.

    We have already removed all default keyboard shortcuts to avoid collisions in our code already. While this is fixed in the nightly build and will be included in the next stable release unfortunately users with existing installations have to disable the shortcuts manually in System Preferences > Keyboard > Shortcuts > Services. Look for any OpenPGP: entry and remove the shortcuts as desired.

    Or you could switch to the beta channel as GPG Suite 2019.1b1 includes the fix. To do this open System Preferences > GPG Suite and tick the beta option, then check for updates.

    The Send report colors for dark mode are also fixed.

    Hope this helps.


  3. 3 Posted by Dimitris Savvop... on 18 Jul, 2019 09:00 PM

    Dimitris Savvopoulos's Avatar

    Indeed, disabling the OpenPGP shortcuts in the preferences solved my problem.

    Stupid me, I skipped the services area when I searched before posting this.

    Thank you so much for your quick response.

  4. Support Staff 4 Posted by Steve on 20 Jul, 2019 05:42 PM

    Steve's Avatar

    Glad this is solved for you. I'm closing this discussion. Should you need further assistance or have questions you can re-open this discussion here or open a new one any time.


  5. Steve closed this discussion on 20 Jul, 2019 05:42 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac