Mail.app on Mojave fails to start after GPGTools installation

Patrick M. Hausen's Avatar

Patrick M. Hausen

01 Jul, 2019 02:29 PM

Hi all,

recently I installed my Mac anew with the latest Mac OS "Mojave". Today it occurred to me that I had not installed GPGTools so I just did that. Now Mail does start and render the menu bar, but no windows. Most menu items are greyed out.

The problem is that the problem persists even after I uninstalled GPGTools again. I went as far as moving ~/Library/Mail and ~/Library/Preferences/com.apple.mail* out of the way - still no banana :-(

What else could I have overlooked? First thing is to get Mail working again. How do I manually remove everything that GPGTools install?

Thanks!
Patrick

  1. Support Staff 1 Posted by Luke Le on 01 Jul, 2019 02:46 PM

    Luke Le's Avatar

    Hi Patrick,

    we are very sorry you are experiencing problems with GPG Suite.
    Unfortunately this happens due to a bug in macOS Mail on Mojave. We have filed the bug with Apple and they believe a fix will be included in 10.14.6.

    Following are the steps that should fix this problem:

    • Close Mail.app
    • Open Terminal and run the following command:

      sudo rm -rf ~/Library/Containers/com.apple.mail/Data/DataVaults

    • Open Mail.app

    After following these steps, Mail should be working properly again.

  2. 2 Posted by Patrick M. Haus... on 01 Jul, 2019 02:49 PM

    Patrick M. Hausen's Avatar

    Geez ... thanks!

    I'm absolutely depending on email working ... which one only ever does notice when it doesn't work.

    Kind regards,
    Patrick

  3. Support Staff 3 Posted by Steve on 01 Jul, 2019 09:12 PM

    Steve's Avatar

    Glad this is solved for you. I'm closing this discussion. Should you need further assistance or have questions you can re-open this discussion here or open a new one any time.

    Best,
    Steve

  4. Steve closed this discussion on 01 Jul, 2019 09:12 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac