GPG Keys only accessible as root

ntr4ef's Avatar


26 Jun, 2019 01:33 AM

Which of our tools is giving you problems? GPG Keychain

Attach a screenshot of the version info for all installed components (how to:

Describe your problem. Add as much detail as possible. I am trying to digitally sign my documents in LibreWriter using the onboard digital signature feature. When I run as a typical Administrator user on MacOS Mojave, I am unable to access the GPG keys to sign my documents. However, when I run soffice as sudo I am able to access the keys (but then I run into other file permission issues...)

What did you expect instead I expected to be able to access my GPG keys while running LibreOffice as an administrator user.

Describe steps leading to the problem. When program faults:
Open LibreOffice from Applications folder. Open preferences > User Data > Cryptography. Drop down menu contains "No Key".

When program works correctly:
Run sudo /Applications/ Open preferences > User Data > Cryptography. Drop down menu contains "No Key" and any personal keys created on device. These are then available for signing documents.

Are you using any other plugins? No.

  1. Support Staff 1 Posted by Steve on 26 Jun, 2019 01:07 PM

    Steve's Avatar

    Hi ntr4ef,

    welcome to the GPGTools support platform. Sorry you are having problems using GPG Suite.

    I am linking a LibreOffice Bugzilla bug for this problem:

    This is a known bug since 2018 february. We hope that TDF, the organisation behind LibreOffice, will raise priority for that bug and assign some dev time to get it fixed.

    Sadly there is nothing we can do from our side to resolve this situation as it needs to be fixed in the LibreOffice code.

    All the best,

  2. ntr4ef closed this discussion on 29 Jul, 2019 05:55 AM.

  3. Steve re-opened this discussion on 08 Feb, 2022 02:40 PM

  4. Support Staff 2 Posted by Steve on 08 Feb, 2022 02:40 PM

    Steve's Avatar

    Hi ntr4ef, seems to have been addressed in LibreOffice by updating gpgme.

    The updated gpgme version has not yet made it into LibreOffice stable branch but can be tested in their latest nightly build from:

    There are remaining problems with the implementation done by LibreOffice, however the initial problem that keys can't even be used is now a thing of the past.


  5. Steve closed this discussion on 22 Feb, 2022 01:18 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac