GPGMail: secret key is not found in GPGMail

Nils's Avatar


02 Jan, 2018 08:53 AM

After Upgrading to HighSierra and 2017.3, I’m unable to sign messages:
Signing your message failed because an unknown error has occured.

gpg: signing failed: No secret key
gpg: signing failed: No secret key

Email will be signed using my private key

Additional info
I use Subkeys and on the CLI using the gpp2 binary shipped with GPGSuite 2017.3 everything is working and I can properly decrypt using my private (sub)keys. I tried to re-import the secret keys (gpg --import < ~/.gnupg/secring.gpg) but this does not change anything.

macOS                   10.13.2     17C88
GPG Suite               2017.3      2087n   (9658b70)
GPGMail                 3.0         1270n   (4060831)
GPG Keychain            1.4.2       1408n   (2e097c4)
GPGServices             1.11.2      971n    (e5438f7)
MacGPG                  2.2.3       899n    (cead4f9)
GPG Suite Preferences   2.1.1       995n    (05eb1a6)
Libmacgpg               0.8.2       828n    (943132e)
pinentry                0.9.7       24n     (bc38c32)
  1. 1 Posted by Nils on 03 Jan, 2018 08:18 AM

    Nils's Avatar

    The issue occurs in GPGSuite 2017.2 - 2017.3 including nightlies. I was able to downgrade to 2017.1b3-v2 an now everything works again, so it think it must be related to the gpg update / migration although I followed the KB guide

  2. Support Staff 2 Posted by Luke Le on 22 Jan, 2018 12:21 PM

    Luke Le's Avatar

    Hi Nils,

    this is an issue we have seen with some users, and have since been able to understand what is happening but not exactly why. Did you use your key on different computers? One cause is, that a user created a new sub key on one computer, but never exported that new sub key to their other computers. After talking to the developer of GnuPG we believe that GnuPG 2.0.X handled this behavior differently than GnuPG 2.2.X, which might also explain why a downgrade to GnuPG 2.0.X (included in 2017.1b3-v2) solves the issue.

  3. 3 Posted by James on 13 Feb, 2018 08:23 PM

    James's Avatar

    @Luke just a heads-up that I tried this downgrade process from 2018.1 to 2017.1b3-v2 on a High Sierra laptop earlier today, and I found that it overwrote my keychain without a confirmation or warning, which seems pretty dangerous.

  4. Support Staff 4 Posted by Steve on 14 Feb, 2018 01:49 PM

    Steve's Avatar

    Should you be available, could you hop on our live chat here:

    We can't promise a solution, but we'd like to inspect this problem in more detail.

    All the best

  5. Support Staff 5 Posted by Steve on 28 Mar, 2018 01:19 PM

    Steve's Avatar

    Where you able to solve this problem? If not, you may want to try the steps outlined below:

    Missing secret and or public keys in GPG Keychain can be a result of a failed migration during an update to GPG Suite which includes gpg 2.2.

    Please visit this KB-article and let me know if that brings you back to working state.

    All the best,

  6. Support Staff 6 Posted by Steve on 18 Jul, 2018 02:00 PM

    Steve's Avatar

    Closing, since no further user feedback was received. Should your problem persist, feel free to re-open this discussion any time.

    All the best, steve

  7. Steve closed this discussion on 18 Jul, 2018 02:00 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac