GPGMail: GPG Suddenly not working in Mac Mail anymore

Adam Bellusci's Avatar

Adam Bellusci

20 Sep, 2018 10:11 PM

Suddenly my encryption options are missing from new messages created in the mac mail client, and I can no longer decrypt mail sent to me. There have been some updates to the Mac recently software wise. Also I have tried the following…

1> Closing out mail and restarting
2> Rebooting the machine
3> Downloading and installing the latest nightly build of GPG Suite to try and fix the problem

Nothing has worked so far.

I expect it to be working as normal

macOS                   10.13.6     17G65
GPG Suite               2018.3      2288n   (bb1237b)
GPGMail                 3.0         1321n   (e24938de)
GPG Keychain            1.4.5       1498n   (25530e6)
GPGServices             1.11.5      1036n   (86cb937)
MacGPG                  2.2.10      920n    (b487092)
GPG Suite Preferences   2.1.3       1051n   (630e0e9)
Libmacgpg               0.8.6       877n    (5e95ff2)
pinentry                1.1.1       26n     (74d8675)
  1. 1 Posted by Jamil on 20 Sep, 2018 10:31 PM

    Jamil's Avatar

    Hello, I'm having exactly the same problem. The only significant change I have made to my machine is updating itunes and safari (the former today and the latter yesterday). I restarted Mail today, after using itunes to update my phone and now the GPGMail plugin is not loading. There is a blank spot where it should be in Mail's prefs but Mail gives me no indication of a failure of the plugin to load.

  2. Support Staff 2 Posted by Steve on 20 Sep, 2018 10:32 PM

    Steve's Avatar

    Hi Adam & Rjamiljonna,

    welcome to the GPGTools support platform. Sorry you are having problems using GPG Suite.

    We are in the midst of preparing the next release of GPG Suite. Until that is ready, please download and install our latest hotfix GPG Suite and see if that solves your problem.

    All the best,

    Disclaimer: This is a development version which has not been thoroughly tested yet - bugs or crashes are to be expected. Thanks for helping us test.

  3. 3 Posted by Jamil on 20 Sep, 2018 10:39 PM

    Jamil's Avatar

    Thanks Adam, that worked.

  4. 4 Posted by v8845t2m on 20 Sep, 2018 10:40 PM

    v8845t2m's Avatar

    TESTING.. thank you for this update.

  5. Support Staff 5 Posted by Steve on 20 Sep, 2018 10:42 PM

    Steve's Avatar

    Hey Prince and Jamil,

    sorry for the hick-up everybody. We are in the midst of preparing the next stable release. It won't be too long now...

  6. 6 Posted by v8845t2m on 20 Sep, 2018 10:46 PM

    v8845t2m's Avatar

    It worked for now.. so we will keep our eyes open for any updates to run tomorrow. Crossing fingers. And thank you folks.

  7. 7 Posted by spwiniarz on 20 Sep, 2018 11:26 PM

    spwiniarz's Avatar

    Confirmed a restart caused the issue of not being able to decrypt/send and the nightly patched it. "Automatically check for updates" is turned on but "include beta builds" is not. There also doesn't seem to be a version difference before and after the restart.
    Could you expand a little on exactly what the issue was and how it impacted a current stable version?

    Thank you for the fast patch!

    Also, hi @prince! <3

  8. 8 Posted by gpg_dude on 21 Sep, 2018 12:10 AM

    gpg_dude's Avatar

    Could you expand a little on exactly what the issue was and how it impacted a current stable version?

    I cannot second this Q enough

  9. Support Staff 9 Posted by Luke Le on 21 Sep, 2018 11:42 AM

    Luke Le's Avatar


    we are deeply sorry for what has happened.
    The GPG Mail version for High Sierra was still a beta. In general our betas have an expiration date in order to avoid people using them for too long after a newer version was released. This beta should have expired in early October, since we knew that by then Apple would have released macOS Mojave. Unfortunately one number of the timestamp we used got mixed up which lead to the early expiration. Since we are in the midst of preparing our newest release we only noticed too late that the date was off.

    The new release is now imminent, but for the time being there's the nightly build Steve linked to.

  10. 10 Posted by marco on 21 Sep, 2018 01:03 PM

    marco's Avatar

    the nightly works, thanks a lot!

  11. 11 Posted by gpg_dude on 21 Sep, 2018 04:47 PM

    gpg_dude's Avatar

    Hi Luke,
    Thanks for the explanation. Aside from the confusion & concern around the production version being "beta" for an OS that is a year old, can you advise how we can detect such an expiration date for future reference? Can it be derived via the installed files or by cracking open the package and inspecting it? Should it perhaps be posted in the release notes so everyone is aware of the limitations of the software they are installing? The last mention of it being beta for 10.13 is: "GPG Suite 2017.2 December 6th, 2017
    Second Beta of GPGMail 3.0 for macOS High Sierra"

    If such a date is even required, in the future could it be set very conservatively (e.g. much further in the future vs. trying to coincide closely with a new OS/GPG release)? This would help avoid future disruptions like this that require wrangling users into installing a nightly release vs. being prompted to install the new stable release.

  12. 12 Posted by jcross on 21 Sep, 2018 05:32 PM

    jcross's Avatar

    Thanks, the hotfix worked for me too.

    Note: the GPGTools Team key (85E3 8F69 046B 44C1 EC9F B07B 76D7 8F05 00D0 26C4) also expired on Aug 19, so you might need to update that from a keyserver to verify the signature (as I had to).

  13. 13 Posted by Arndt Humpert on 22 Sep, 2018 11:04 AM

    Arndt Humpert's Avatar


  14. Support Staff 14 Posted by Steve on 17 Oct, 2018 06:10 PM

    Steve's Avatar

    I'm closing this discussion. Should you need further assistance or have questions you can re-open this discussion here or open a new one any time.


  15. Steve closed this discussion on 17 Oct, 2018 06:10 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac