GPG Keychain: Broken pubring.kbx file?

Paweł Sobierski's Avatar

Paweł Sobierski

31 Aug, 2018 02:27 AM

GPG Keychain has stopped seeing me any keys. Even when a new one is added, it does not show up on the list.
After entering in terminal the "gpg -k" command, the following message appears:

When I delete the .gnupg directory, I can then import or add new keys.


macOS                   10.14       18A377a
GPG Suite               2018.3      2273n   (bb1237b)
GPGMail -
GPG Keychain            1.4.4       1485n   (a49d8cc)
GPGServices             1.11.4      1028n   (6d78936)
MacGPG                  2.2.9       919n    (bdecf9e)
GPG Suite Preferences   2.1.2       1047n   (312afda)
Libmacgpg               0.8.5       871n    (15e192d)
pinentry                1.1.1       26n     (74d8675)
  1. Support Staff 1 Posted by Steve on 02 Sep, 2018 05:44 PM

    Steve's Avatar

    Hi Paweł,

    welcome to the GPGTools support platform. Sorry you are having problems using GPG Suite.

    Can you follow the steps in the following KB article and let us know if that brings back your keys:


  2. 2 Posted by Paweł Sobierski on 03 Sep, 2018 10:53 AM

    Paweł Sobierski's Avatar

    Problem solved.
    I deleted the pubring.kbx and trust.db files.
    GPG has created a new profile. I downloaded my public keys from the key server, and then from the backup I restored all private keys from the "private-keys-v1.d" folder as well as from the "openpgp-revocs.d" - revocation certificates.
    Everything works as it should.
    Thank you and best regards.

    On [DATE], "[NAME]" <[ADDRESS]> wrote:

  3. Support Staff 3 Posted by Steve on 05 Sep, 2018 02:59 PM

    Steve's Avatar

    That's good news.

    Glad, this is solved for you. I'm closing this discussion. Should you need further assistance or have questions you can re-open this discussion here or open a new one any time.


  4. Steve closed this discussion on 05 Sep, 2018 02:59 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac