Trying to donate to you via PayPal fails if message is too long

Jan Gronemann's Avatar

Jan Gronemann

13 Jan, 2018 10:38 PM

I tried to donate money to you via PayPal. I attached the note in the following paragraph. I got the error "There are currently problems, please try again later."
In a separate tab, I logged in to PayPal to verify that it was up, then I re-tried donating a few times. After diddling around a bit, I think the reason is that PayPal has a length limit that your message box does not enforce, and they don't sanitize their inputs properly so the entire payment fails.

"You really should set up some Cryptocurrency donation options, like Monero (99.999% private) or Bitcoin Cash (sub-cent transfer fees), or better yet, find a non-PayPal payment processor who handles the "bothersome" parts of crypto for you. PayPal is known to censor politically incorrect views and should be avoided."

What did you expect instead

Giving you my monies

Describe steps leading to the problem.

Put lots of text into the message field on your donation page

Are you using any other plugins?

Not relevant.

  1. Support Staff 1 Posted by Luke Le on 17 Jan, 2018 06:52 PM

    Luke Le's Avatar

    Hi Jan,

    thank you very much for your interest in our suite and wanting to support the development.
    We will look into the issue with the length restriction for the comment field.
    As for your suggestion with accepting crypto currency, unfortunately we have had a bad experience in the past and don‘t want to repeat that. In addition, the fluctuation of the value which affects many different cryptocurrencies is a pain.
    We will however revisit the option from time to time.

    Thanks again for the report and have a nice evening

  2. Steve closed this discussion on 26 Mar, 2018 06:55 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac