xlc service is not working properly

Albert Lazzarini's Avatar

Albert Lazzarini

12 Dec, 2017 09:48 PM

Which of our tools is giving you problems? GPGMail

Attach a screenshot of the version info for all installed components (how to: https://gpgtools.tenderapp.com/kb/faq/where-can-i-find-version-info...): See attached PDF document with 3 screen shots:
- version information - popup I get overtime I send a signed message - popup I get when I select "cancel" on entering my passphrase.

Describe your problem. Add as much detail as possible. I installed 2017.2 and I am required to provide my pass phrase EVERY time I send a signed or encrypted message. I attach a PDF file showing the various popup messages I get.

What did you expect instead The message would be sent either encrypted or signed without my requiring to enter my passphrase each time. That is how it used to work.

Describe steps leading to the problem. I updated GPOGTools a week or so ago. But this only started happening. I reinstalled 2017.2 just before filing this report as instructed on one of the popup messages.

Are you using any other Mail.app plugins? Not that I know of.

  1. Support Staff 1 Posted by Luke Le on 13 Dec, 2017 02:48 PM

    Luke Le's Avatar

    Hi Albert,

    we are very sorry to hear you are experiencing problems with the latest version of GPG Suite.
    We believe this problem is triggered if a user has a custom GnuPG version installed along side of our MacGPG. From the debug log I can tell that that is the case for you.

    Could you please download and install our latest GPG Suite nightly build and see if it solves your problem. That page also has sig and SHA256 to verify the download.
    Please log out and back in after installing the nightly.

    Disclaimer: This is a development version which has not been thoroughly tested yet - bugs or crashes are to be expected. Thanks for helping us test.

  2. 2 Posted by Albert Lazzarin... on 13 Dec, 2017 07:33 PM

    Albert Lazzarini's Avatar

    Yes, the uninstall and reinstall of the nightly build worked.
    Thank you.

  3. Support Staff 3 Posted by Steve on 13 Dec, 2017 07:43 PM

    Steve's Avatar

    Perfect. Glad, this is solved for you. I'm closing this discussion. Should you need further assistance or have questions you can re-open this discussion here or open a new one any time.


  4. Steve closed this discussion on 13 Dec, 2017 07:43 PM.

  5. Steve closed this discussion on 14 Dec, 2017 05:04 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac