Error while encrypting a file with gpg -c filename

Rishi's Avatar


11 Oct, 2017 12:32 PM

Which of our tools is giving you problems? linux 4.1.12-94.5.9.el6uek.x86_64

Attach a screenshot of the version info for all installed components (how to: NA

Describe your problem. Add as much detail as possible. After installing gpg, when i tried to encrypt a file using gpg i am getting below error.Is there any configuration missing after installing gpg???

gpg -c

gpg: cancelled by user gpg: error creating passphrase: Operation cancelled gpg: symmetric encryption of `' failed: Operation cancelled

What did you expect instead Enter Passphrase

Describe steps leading to the problem.

I installed gpg in my new environment after installing gpg i directly tried to encrypt a simple file but getting error

Are you using any other plugins? No

  1. Support Staff 1 Posted by Luke Le on 13 Oct, 2017 04:03 PM

    Luke Le's Avatar

    Hi Richie,

    if you run the command with the option --debug-level guru you should see a lot more helpful output.
    Since you are using Linux it's best to ask the developers of GnuPG directly on or on their user mailing list:

    Hope that helps.

  2. Steve closed this discussion on 26 Feb, 2018 12:38 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac