Signing with a Yubikey fails until I run `gpg --card-status`

Marco's Avatar


20 Dec, 2020 05:05 PM

Which of our tools is giving you problems? GPG services (probably)

Attach a screenshot of the version info for all installed components (how to:

Describe your problem. Add as much detail as possible. I set up my Yubikey to hold my encryption, signing, authentication subkeys. The public key is stored in GPG Keychain. When I first insert the Yubikey and then try to sign a file from the service menu it fails, until I run gpg --card-status, after which I can sign successfully until I unplug/re-plug the Yubikey.

I think I'm not the only one with this problem (see first answer):

What did you expect instead I expect the signing to always work without the gpg --card-status hack

Describe steps leading to the problem. Plug in a Yubikey with a signing key, try to sign anything, watch it fail. Run gpg --card-status, try to sign a file again and it will work until the key is unplugged. Rinse and repeat.

Are you using any other plugins? No

  1. Support Staff 1 Posted by Steve on 21 Dec, 2020 11:21 AM

    Steve's Avatar

    Hi Marco,

    thank you for taking the time to report this problem. We apologize for the bad experience.

    This issue is likely related to a regression introduced in GnuPG 2.2.24 which should be fixed in 2.2.25.

    Could you please download and install our latest hotfix GPG Suite and see if that solves your problem.

    All the best,

    Disclaimer: Hotfixes are GPG Suite builds containing our latest source code, so bugs and crashes may occur.

  2. 2 Posted by Marco on 21 Dec, 2020 10:35 PM

    Marco's Avatar

    Yes, the nightly version does indeed fix the problem!

  3. Support Staff 3 Posted by Steve on 22 Dec, 2020 05:13 PM

    Steve's Avatar

    Glad this is solved for you. I'm closing this discussion. Should you need further assistance or have questions you can re-open this discussion here or open a new one any time.


  4. Steve closed this discussion on 22 Dec, 2020 05:13 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac