MacGPG: selecting card failed: Operation not supported by device

Xavier Mertens's Avatar

Xavier Mertens

25 Nov, 2020 06:22 AM

Which of our tools is giving you problems?


Attach a screenshot of the version info for all installed components (how to:

Latest version (2020.1)

Describe your problem. Add as much detail as possible.

After a reboot of my MacOS (Big Sur), keys stored on my USB Nano 4 Yubikey key are not availlable. It was working properly before the reboot. I rebooted, killed gpg-agent, scdaemon, etc... No way :(

$ gpg --card-status gpg: selecting card failed: Operation not supported by device
gpg: OpenPGP card not available: Operation not supported by device

What did you expect instead


Describe steps leading to the problem.


Are you using any other plugins?

No, still waiting for the new version :-)

  1. 1 Posted by Xavier Mertens on 25 Nov, 2020 06:29 AM

    Xavier Mertens's Avatar

    More info:

    • The card is working (recognized by the OS)
    • The Yubikey OTP are generated
    • It was working before the last reboot
  2. Support Staff 2 Posted by Steve on 25 Nov, 2020 08:12 PM

    Steve's Avatar

    Hi Xavier,

    welcome to the GPGTools support platform. Sorry you are having problems using GPG Suite.

    Could you update to GPG Suite 2020.2 from our website and see if that changes anything for the better or worse.


  3. 3 Posted by Patrick Mulln on 25 Nov, 2020 10:12 PM

    Patrick Mulln's Avatar

    I am having the exact same problem, am on 2020.2 and my yubikey based secret keys are not functioning after the update.

  4. 4 Posted by Xavier Mertens on 26 Nov, 2020 06:59 AM

    Xavier Mertens's Avatar

    Some update... I've absolutely NO idea but the Yubikey was detected again later during the day... I did not change anything!?

  5. Support Staff 5 Posted by Steve on 26 Nov, 2020 08:48 PM

    Steve's Avatar

    Hi Xavier and Patrick,

    we apologize for the bad experience.

    This issue could be related to a regression introduced in GnuPG 2.2.24 which should be fixed in 2.2.25:

    We are currently in the process of preparing a hotfix with GnuPG 2.2.25 and will inform you once that is available.


  6. 6 Posted by Xavier Mertens on 26 Nov, 2020 10:08 PM

    Xavier Mertens's Avatar

    Tx! BTW, any idea about the availability of the upgrade compatible with Big Sur?

  7. Support Staff 7 Posted by Steve on 26 Nov, 2020 10:18 PM

    Steve's Avatar

    GPG Suite 2020.2 is available from our website. We started slowly rolling out automatic updates today. This is a slow roll out so you may not see it if you check via automatic check. This will be changed in the coming days. But you can always download from our website.

  8. 8 Posted by Xavier Mertens on 26 Nov, 2020 10:39 PM

    Xavier Mertens's Avatar

    Great news! Tx!

  9. Support Staff 9 Posted by Steve on 01 Dec, 2020 12:17 AM

    Steve's Avatar

    Hi Xavier,

    could you please download and install our latest hotfix GPG Suite and see if that solves your problem. We have integrated MacGPG 2.2.25 which includes a fix for a regressing introduced in GnuPG 2.2.24.

    All the best,

    Disclaimer: Hotfixes are GPG Suite builds containing our latest source code, so bugs and crashes may occur.

  10. 10 Posted by jcross on 13 Dec, 2020 11:08 PM

    jcross's Avatar

    I was having the same issues with 2.2.24 and wanted to report your 2.2.25 hotfix fixed it.

  11. Support Staff 11 Posted by Steve on 14 Dec, 2020 02:17 PM

    Steve's Avatar

    Thanks for the feedback jcross 👍

    Glad this is solved for you. I'm closing this discussion. Should you need further assistance or have questions you can re-open this discussion here or open a new one any time.


  12. Steve closed this discussion on 14 Dec, 2020 02:17 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac