wrapping issue / reading mail from PGP non-commercial users

Juraj Bednar's Avatar

Juraj Bednar

01 Apr, 2015 09:40 AM


people using non-commercial version of PGP send this header in ASCII armor:

Version: PGP Desktop 10.2.0 (Build 1672) - not licensed for commercial use: www.pgp.com

This is wrapped in Mail.app to two lines and then sent to GPG, which says that the armor has invalid characters. Since PGP sends this correctly (without wrapping) it's clearly a mailapp/gpgtools
issue (I can read these e-mails in Thunderbird+Enigmail or R2MAIL2 on my phone, but not in

  1. 1 Posted by Ben on 03 Apr, 2015 04:44 AM

    Ben's Avatar

    While it is almost certainly true that Mail and GPGTools are doing the wrapping (more likely just Mail.app is and then GPGTools falls because the new line breaks the expected fields), it is also true that the PGP Desktop string is way too long. All OpenPGP messages are base64 encoded and the version or comment lines need to fit within that, but the PGP Desktop string there is 87 characters long.

    Symantec need to change that to something like this (but they probably won't):

    Version: PGP Desktop 10.2.0 (Build 1672)
    Comment: not licensed for commercial use: www.pgp.com
  2. 2 Posted by Juraj Bednar on 03 Apr, 2015 02:19 PM

    Juraj Bednar's Avatar

    It's all true and the fact is it would be great to fix this problem even if Symantec fixes PGP Desktop - because of the tons of users who just won't upgrade.

    I reported this back to Symantec to fix it on their side, but I would like to see even an official workaround for people who just have to deal with this type of correspondence.

  3. 3 Posted by Ben on 03 Apr, 2015 03:19 PM

    Ben's Avatar

    Then you need to see if there's an option in Mail.app to not
    automatically word-wrap long lines, because chances are extremely high
    that that's what's adjusting the line and splitting it.

    GPGTools just passes any message block which begins and ends with the
    relevant lines (BEGIN PGP MESSAGE and END PGP MESSAGE) to the GPG
    command line program and it operates according to the OpenPGP standard
    (which is why the other clients you mentioned work).

  4. Support Staff 4 Posted by Steve on 25 Jun, 2015 11:07 AM

    Steve's Avatar

    Hi Juraj,

    while as discussed already this isn't a bug, it would indeed still be great, if we could deal with this form of malformed content.

    We have a ticket for this problem. I connected this discussion with the existing ticket. That means, should this discussion get closed, it will be re-opened as soon as the ticket is closed. That way you'll receive a notification. Feel free to open a new discussions should you run into further problems or need assistance.

    All the best,

  5. Steve closed this discussion on 25 Jun, 2015 11:07 AM.

  6. Support Staff 5 Posted by Steve on 05 Jul, 2015 10:36 AM

    Steve's Avatar

    Hi Juraj,

    good news. We think, this issue has been fixed. If you want to test the fix, please download our latest nightly GPG Suite. That page also has sig and SHA1 to verify the download. It would be very helpful, if you can provide feedback, as to wether the fix works as expected.

    If you have other questions you can open a new discussion any time.

    Best, steve

    Disclaimer: This is a development version which has not been thoroughly tested yet, so bugs or crashes are to be expected. Thanks for helping us test this fix.

  7. 6 Posted by Juraj Bednar on 06 Jul, 2015 01:47 PM

    Juraj Bednar's Avatar

    Thanks, this fixed the issue, thank you very much!

  8. Support Staff 7 Posted by Steve on 06 Jul, 2015 06:34 PM

    Steve's Avatar

    Perfect. Glad, this is solved for you. I'm closing this discussion. If you need further assistance or have questions you can re-open this discussion here or open a new one any time.

    Best, steve

  9. Steve closed this discussion on 06 Jul, 2015 06:34 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac