GPG Services: Cannot disable default keyboard shortcuts

Adam Hawtin's Avatar

Adam Hawtin

09 May, 2019 08:18 AM

The cmd+shift+F default keyboard shortcut conflicts with other programs I use so I need to disable it completely. I have tried unchecking the shortcut in the Mac keyboard settings, deleting the keymapping and remapping it to something else but the behaviour ALWAYS persists, cmd+shift+F is still inserting my key. I have tried restarting the machine, uninstalling and reinstalling GPG-suite and installing the beta build but the keyboard shortcut always remains working.

Expected
The keyboard shortcut to stop working when I disable it in the system settings.

Additional info
Mac OS version 10.14.4
I’ve installed GPG-suite with the 2018.5 version installer and also the 2019.1b1 beta branch

macOS                   10.14.4     18E227
GPG Suite               2019.1b1    2436    (e282cf1)
GPG Mail    -
GPG Keychain            1.4.7b1     1529    (7445c46)
GPG Services            1.11.7b1    1074    (71fac01)
MacGPG                  2.2.15      896     (30642a7)
GPG Suite Preferences   2.1.5b1     1088    (3d1f7c6)
Libmacgpg               0.8.8b1     902     (fedc7b5)
pinentry                1.1.0.1b1   12      (c3f5edf)
  1. 1 Posted by Adam Hawtin on 10 May, 2019 08:53 AM

    Adam Hawtin's Avatar

    An update from me:
    After several more machine restarts the problem has gone away. I can't say exactly which step actually resolved the issue but after unmapping and disabling the shortcuts, then restarting the machine more than once it seems to have resolved itself.

  2. Support Staff 2 Posted by Steve on 10 May, 2019 03:02 PM

    Steve's Avatar

    Hi Adam,

    thanks for getting in touch about this problem.

    We have already removed all default keyboard shortcuts to avoid collisions in our code already. While this is fixed in the nightly build and will be included in the next stable release unfortunately users with existing installations have to disable the shortcuts manually in System Preferences > Keyboard > Shortcuts > Services. Look for any OpenPGP: entry and remove the shortcuts as desired.

    Glad this is already solved for you. Should you need further assistance or have questions you can re-open this discussion here or open a new one any time.

    Best,
    Steve

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac