GPG Mail: PGP and S/mime not working

Oliver's Avatar

Oliver

17 Apr, 2019 02:49 PM

Hello

I can not send encrypted mails using PGP or S/MIME and decrypt PGP mails. The OpenPGP-Icon is grey and not clickable. The padlock and seal icon are missing, too. Last week I sent encrypted messages (PGP and SMIME) but since monday I can not send encrypted mails to the same people.

I am using AppleMail (Version 11.5 [3445.9.1]) and GPG Mail 3.0.2b1 build: 1363b

I do not want to move to Thunderbird....

Best
Oliver

PS: I do not like to accept java-scripts from google (when reporting a bug) to verify that I am not a robot...........

  1. Support Staff 1 Posted by Steve on 17 Apr, 2019 02:53 PM

    Steve's Avatar

    Hi Oliver,

    welcome to the GPGTools support platform. Sorry you are having problems using GPG Suite.

    Does this persist after a restart? And if so, could you double check both your key and subkey are ok?

    In case the issue persists, could you please send a debug log from your affected machine: Open System Preferences > GPG Suite > Send Report. Check the box to "attach debug log". Since you already described your issue in this discussion, you don't need to add a lot of detail, but please do add the link to your existing discussion, so I can then merge your debug info with this existing discussion.

    All the best,
    Steve

    PS: You could use System Preferences > GPG Suite > Send Report. We don't like Google Captchas either but sadly without them, this forum would drown in spam.

  2. 2 Posted by Oliver on 29 Apr, 2019 12:22 PM

    Oliver's Avatar

    Hello,

    Bug reporting does not work. GPG Suite in System Preferences does not open itself and I have to quit System Preference with "Force Quit". On my other mac book (without GPG Suite) S/MIME works fine.
    I still have the problem after restarting my MacBook.

    Best
    Oliver

  3. Support Staff 3 Posted by Steve on 29 Apr, 2019 12:45 PM

    Steve's Avatar

    This sounds very wrong

    Please search for any relevant crashlogs. To search for crashlogs:

    • open new finder window
    • press ⇧⌘G
    • paste '~/Library/Logs/DiagnosticReports'

    We are looking for anything with gpg2, Mail, GPGServices, GPG Keychain, Libmacgpg or pinentry in the name. The date indicates if the crashlog is fresh or old.

    Repeat above steps but this time paste '/Library/Logs/DiagnosticReports' and again look for relevant crashlogs.

    When you find something relevant, please attach the crashlog to your existing discussion.

    Are you able to send yourself an encrrypted messages using OpenPGP? Same question for S/MIME.

  4. 4 Posted by Oliver on 02 May, 2019 06:59 AM

    Oliver's Avatar

    Hi,

    I can not encrypt mails with OpenPGP or S/MIME to myself or others.
    I can not decrypt OpenPGP mails. I can only decrypt S/MIME mails.
    I did not found any log files. Sorry!
    How can I move to a non-beta version?

    Best
    Oliver

  5. Support Staff 5 Posted by Luke Le on 02 May, 2019 10:01 AM

    Luke Le's Avatar

    Hi Oliver,

    you could simply re-install the official release from our website. But this sounds like a different problem.

    Could you please open Terminal and run the following commands and post its output:

    ls -l ~/.gnupg/
    gpg -K
    

    Thanks!

  6. 6 Posted by Oliver on 03 May, 2019 08:28 AM

    Oliver's Avatar

    Hi Luke,

    Thank you for your hint. I solved the problem and pgp in AppleMail works fine.
    A dead process still locked a key file. I carefully removed the locked file in the gnupg folder (.gnupg).

    I think GPGmail probably was not the problem. Sorry! But I am still confused how Enigmail worked..

    Thanks and have a nice weekend.
    Best
    Oliver

  7. Support Staff 7 Posted by Luke Le on 03 May, 2019 08:30 AM

    Luke Le's Avatar

    Hi Oliver,

    great to hear that. Yeah, that was my suspicion. It's not really clear to me why GnuPG doesn't delete the file itself if it finds that the related process is no longer alive.

    It sure is interesting that Enigmail continued working. They might be invoking GnuPG differently. I will have a look.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac