beta expiered under OS X 10.10.2

alwillis's Avatar


05 Jan, 2015 09:35 AM

I’m getting the same error—and I’ve installed GPG Suite Beta 4 several times now.

I’m on the latest public beta of Yosemite 10.10.2; I’ve installed all of the components of GPG Suite Beta 4 except MacPGP2 because I already have GnuPG 2.1.1 installed.

Also, GPG Keychain is unable to display signatures on any keys accept my own. I know there was a change in the key storage format in GnuPG 2.1. I’ve attached a screenshot what GPG Keychain displays.

This setup worked fine with Beta 3 of GPG Suite, so I was surprised when Beta 4 didn’t work.

  1. Support Staff 1 Posted by Steve on 05 Jan, 2015 09:55 AM

    Steve's Avatar

    Hi alwillis,

    are you running OS X 10.10.2 (14C81f)?

    Just tested this and GPGMail worked fine here. We've not found the time to integrate GPG 2.1. GPG Suite Beta 4 contains the latest stable release (2.0.26).

    Could you try removing GnuPG 2.1.1 and reinstall the MacGPG2 that comes with the Suite and let us know if you're back to working state then?

    All the best,

  2. 2 Posted by Alex on 05 Jan, 2015 04:10 PM

    Alex's Avatar


    Confirm bug, also tried to install GPG Suite Beta 4, but still getting "Your GPGMail beta has expired" at Mail start.

    Now I can not use GPG in Mail, back to S/MIME again :(

  3. 3 Posted by Thomas on 05 Jan, 2015 04:45 PM

    Thomas's Avatar

    Same for me. Downloaded GPG Suite Beta 4 on Yosemite. Installed and immediately got the following message when starting

    "Your GPGMail Beta has expired

    You can no longer use this version of GPGMail. Please visit to download the newest version."

  4. 4 Posted by alwillis on 05 Jan, 2015 06:17 PM

    alwillis's Avatar

    I’m actually running Yosemite 14C81h.

    I understand you haven’t integrated support for “modern GnuPG” (2.1 and above); was hoping things would just work.

    I’ll downgrade to the regularly installed GnuPG and report back if I have any problems.

  5. 5 Posted by Thomas on 05 Jan, 2015 08:05 PM

    Thomas's Avatar

    In mij case I'm using the Homebrew provided version of gnupg2 (not the gpgtools package that comes with the beta 4 installer).

    Could that be the reason for the expiration warning?

  6. Support Staff 6 Posted by Steve on 05 Jan, 2015 08:32 PM

    Steve's Avatar

    The bad thing is, 10.10.2 14C81f seems to close to 14C81h, so we do not see any update offered from Apple. And then again Apple forbid direct links to dev seeds in the developer forum to get access to new versions. Great combination.

  7. Support Staff 7 Posted by Steve on 08 Jan, 2015 07:53 AM

    Steve's Avatar

    Yesterday Apple released 10.10.2 (14C94b) and it works fine with GPG Suite Beta 4. If you are seeing any expired message please:

    re-download Beta 4, uninstall and reinstall. Then update to the latest dev seed from Apple.

    If any issues persist and you still see the expired message, please open a separate discussion (it's easier for us if we have one discussion per person in this case, because the reasons for that problem can be various and having several users in one discussion makes it very hard to keep track).


  8. Support Staff 8 Posted by Luke Le on 08 Jan, 2015 11:29 AM

    Luke Le's Avatar

    Hi Thomas,

    if you're using gnupg from homebrew you'll have to refresh our team @ key from the key server or re-import it from
    After that, you should no longer see the expired message.

  9. Support Staff 9 Posted by Steve on 15 Jan, 2015 10:13 AM

    Steve's Avatar

    10.10.2 (14C99d) GPGMail is ok.

  10. Steve closed this discussion on 28 May, 2015 04:54 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac