MacGPG2 #148: getting "PIN-Entry helper" defective

smith's Avatar


10 Dec, 2014 12:19 PM

GPGMail 2.5b3

I installed b3 when it came out and it worked fine. Since today I am getting the following message when I sign an email (which is on by default in my preferences)

What did you expect instead

no error

Describe steps leading to the problem.

  1. open a new email
  2. enable signing
  3. send

If your problem concerns GPGMail, are you using any other plugins?


  1. Support Staff 1 Posted by Luke Le on 10 Dec, 2014 12:25 PM

    Luke Le's Avatar

    Hi Lukas,

    since the issue is now fixed after re-installing I have a few questions.
    Was your computer in standby not too long before seeing this problem?

  2. 2 Posted by smith on 10 Dec, 2014 12:26 PM

    smith's Avatar

    Hmm not sure. I think it was at least 20min since I got back from lunch.

  3. Support Staff 3 Posted by Luke Le on 10 Dec, 2014 12:35 PM

    Luke Le's Avatar

    And do you remember if there was a pinentry dialog visible (or not active) at the moment of sending?

    We're currently speculating that there might be a problem, where a non-active pinentry-dialog is still visible and a new one is requested, the new one times out, because the old one is still waiting for a response.

  4. 4 Posted by smith on 10 Dec, 2014 12:38 PM

    smith's Avatar

    no .. there was no dialog open

  5. Support Staff 5 Posted by Steve on 02 Jan, 2015 12:46 AM

    Steve's Avatar

    Hey Lukas,

    did this ever re-appear on your system?


  6. 6 Posted by smith on 02 Jan, 2015 10:42 AM

    smith's Avatar

    no, so far it has not re-appeared

  7. Support Staff 7 Posted by Steve on 02 Jan, 2015 03:03 PM

    Steve's Avatar

    Ok, thanks for the feedback.

    We're not sure yet, what is causing this behavior. As Luke pointed out we do have a few suspicions and are observing this closely.

    I'm closing this discussion. If you need further assistance or have questions you can re-open this discussion here or open a new one any time.

    Best, steve

  8. Steve closed this discussion on 02 Jan, 2015 03:03 PM.

  9. Steve re-opened this discussion on 03 Jan, 2015 02:31 PM

  10. Steve closed this discussion on 03 Jan, 2015 02:32 PM.

  11. Steve re-opened this discussion on 05 Jul, 2015 03:11 PM

  12. Support Staff 8 Posted by Steve on 05 Jul, 2015 03:11 PM

    Steve's Avatar

    Hi Lukas,

    good news. We think, this issue has been fixed. If you want to test the fix, please download our latest nightly GPG Suite. That page also has sig and SHA1 to verify the download. It would be very helpful, if you can provide feedback, as to whether the fix works as expected.

    If you have other questions you can open a new discussion any time.

    Best, steve

    Disclaimer: This is a development version which has not been thoroughly tested yet, so bugs or crashes are to be expected. Thanks for helping us test this fix.

  13. 9 Posted by smith on 06 Jul, 2015 07:37 AM

    smith's Avatar

    I encountered the issue 3 times in the last 6 months and each time I fixed it by simply installing again. So I am afraid I will not really be much help in confirming if this fix does the trick :-/

  14. Support Staff 10 Posted by Steve on 06 Jul, 2015 10:04 AM

    Steve's Avatar

    Sure. Well we think it should be finally fixed. You can just re-open should the issue re-appear even after installing the latest nightly.

  15. Steve closed this discussion on 06 Jul, 2015 10:04 AM.

  16. Steve closed this discussion on 24 Jul, 2015 09:22 AM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac