pinentry-mac does not unhide pass phrase properly

Dimitry Andric's Avatar

Dimitry Andric

03 Dec, 2014 11:36 PM

When you are typing your pass phrase into pinentry-mac, by default the characters are hidden, as shown in the first screenshot. However, if you then check the "Show typing" box, only the first character of the pass phrase is unhidden, as shown in the second screenshot. In the previous version of GPGTools, this worked just fine, so this is a regression.

Another minor nit is that the "Save in Keychain" text label appears to be slightly cut off. This may be due to the new default system font in Yosemite.

  1. 1 Posted by wingman on 04 Dec, 2014 09:24 AM

    wingman's Avatar

    Hi Dimitry

    the minor issue with the "save in keychain" text label has been already fixed (available if you are using the nightly build)

    The "typing issue" is a known bug and the team is already working on this


  2. 2 Posted by wingman on 07 Jan, 2015 03:15 PM

    wingman's Avatar

    Hi Dimitry

    The issue has now been fixed with beta 4. Could you please try this and post back if you still face issues ?


  3. 3 Posted by Dimitry Andric on 07 Jan, 2015 05:42 PM

    Dimitry Andric's Avatar

    Hi Wingman,

    Yes, it works fine now with beta 4. Checking and unchecking the "Show typing" box shows and hides the text correctly, without mangling it.

    Thanks for the fix.

  4. Support Staff 4 Posted by Steve on 07 Jan, 2015 06:03 PM

    Steve's Avatar

    Perfect. Glad, this is solved for you. I'm closing this discussion. If you need further assistance or have questions you can re-open this discussion here or open a new one any time.

    Best, steve

  5. Steve closed this discussion on 07 Jan, 2015 06:03 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac