GPG Keychain "Missing self-signature" error

koev36's Avatar


25 Nov, 2014 05:54 PM

This comment was split from the discussion: GPG keychain does not - always - work in Yosemite (MacGPG2 #141 FIXED)

I get the same "missing self signature - import failed" error when I try to import my transfered secure key (never had a problem doin' it before).

I am also using an iMac mid 2007 with Yosemite

  1. Support Staff 1 Posted by Steve on 27 Nov, 2014 11:09 AM

    Steve's Avatar

    Hi koev36,

    can you please open your sec/pub key on the original machine (not the machine you are trying to import to). To do that, open GPG Keychain and double click your sec/pub key entry. Then open the subkey tab and check the expiry date of your subkey. Also check the validity.

    Then open the UserID tab and check the signatures area. What is displayed there? Is there a signature with your own name? If so, is that maybe expired?

    All the best,

  2. 2 Posted by koev36 on 27 Nov, 2014 06:55 PM

    koev36's Avatar


    expiry is empty (cause I didn't want in to expire)

    Validity says "Unbekannt" which means "unknown"

  3. Support Staff 3 Posted by Steve on 27 Nov, 2014 07:20 PM

    Steve's Avatar

    That is the case for both subkey and signature in UserID tab?

  4. 4 Posted by koev36 on 27 Nov, 2014 07:22 PM

    koev36's Avatar


  5. 5 Posted by Gerd on 28 Nov, 2014 02:53 PM

    Gerd's Avatar

    Should be fixed with last nights fix.
    Had the same issue, also 2007 iMac

    Luc should have fixed it. It works now for me perfectly.

  6. 6 Posted by koev36 on 28 Nov, 2014 03:07 PM

    koev36's Avatar

    works again. How do I get a green validity though?

    Thanks for the support!

  7. Support Staff 7 Posted by Steve on 28 Nov, 2014 03:29 PM

    Steve's Avatar

    koev36, thanks for the feedback.

    First off: green validity isn't "better" than red. It just means that you indeed did validate who the key owner is. Now for your own keys, you can set it to ultimate, since you're the person who created those keys.

    If you transfer your keys, that trust level will not get transported over to the new machine. So you have to manually change the trust level for your sec/pub keys after transfer.

    Let me know if that worked and if you do have more questions,

  8. Steve closed this discussion on 13 Dec, 2014 11:25 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac