"Show Typing" appears broken

cliff1976's Avatar


06 Nov, 2014 06:40 AM

Thanks for the beta.

I found 1 possible issue, one definite. This is the definite issue (the possible issue will be entered separately): the PIN entry dialog appears to have broken "Show Typing" functionality. I typed in my passphrase (apparently incorrectly) and checked the box to "Show Typing". The many dots obscuring my passphrase were replaced not with my keyboard input, but rather just its first character.

This was not a problem before upgrading to the Yosemite beta; "Show Typing" definitely used to show all the characters I input.

Attaching two screenshots.

  1. 1 Posted by cliff1976 on 11 Nov, 2014 08:16 PM

    cliff1976's Avatar

    Update: I'm now running version 2.5b1 build 790b and this problem is still occurring. Oddly, it's only happening on the passphrase for one of my keys. On the other key, the Show Typing functionality works just as expected.

  2. 2 Posted by Mosys on 13 Nov, 2014 05:07 PM

    Mosys's Avatar

    Same here. Entering the password, then enabling "Show Typing" removes all but the first character of the already entered password.

  3. 3 Posted by cliff1976 on 15 Nov, 2014 10:21 AM

    cliff1976's Avatar

    Another update: "Show Typing" is still broken after installing GPG Suite - 2014.11.Yosemite-b2.dmg.

  4. 4 Posted by cliff1976 on 22 Nov, 2014 07:35 AM

    cliff1976's Avatar

    Still no progress on this topic after getting the following versions installed:

    GPGMail: 2.5b2 build 792b
    GPG Keychain: 1.2b1(5a2f7bc) build 949n
    GPGServices: 1.10b2 (ac24bd0 build 701n
    MacGPG2: 2.0.26b1 (c11a4af) build 687n
    GPGPreferences: 1.5b1 (4033620) build 702n

  5. 5 Posted by cliff1976 on 26 Nov, 2014 06:17 AM

    cliff1976's Avatar

    Still broken with the latest nightly build for GPG Keychain.

    GPGMail: 2.5b2 build 792b
    GPG Keychain: 1.2b1(a0ec16a) build 951n
    GPGServices: 1.10b2 (ac24bd0 build 701n
    MacGPG2: 2.0.26b1 (c11a4af) build 687n
    GPGPreferences: 1.5b1 (4033620) build 702n

  6. 6 Posted by cliff1976 on 26 Nov, 2014 06:31 AM

    cliff1976's Avatar

    I just realized that you might have trouble reproducing this bug if you are copying/pasting your passphrases into the PINentry dialog box instead of typing them in by hand.

    For some of my keys I tend to type in the passphrase by hand, and others I paste in. I noticed this bug on the ones I type in, but if I change it up and paste in the passphrase for that, it works fine. Likewise, if I try to type in the passphrase on the keys I usually paste in, the bug appears.

    Maybe this extra hint is enough to get some attention from the developers on this bug! :-)

  7. 7 Posted by wingman on 27 Nov, 2014 04:23 PM

    wingman's Avatar

    Hi cliff1976

    I think Luke is already aware of this and he is working towards a fix (we did replicate this over our team viewer session today)


  8. 8 Posted by cliff1976 on 27 Dec, 2014 12:50 PM

    cliff1976's Avatar

    Hooray, it working with the latest available nightly build of MacGPG2 now! Thanks for fixing it!

  9. Support Staff 9 Posted by Steve on 29 Dec, 2014 08:28 PM

    Steve's Avatar

    Hi all,

    Cliff thanks a lot for taking the time to report this initially and Mosys for chiming in on this.

    Please excuse our silence. This issue indeed has been fixed a few days ago so cliff was right on it. I've connected the corect ticket for this problem with this discussion.

    And again, thanks cliff for already verifying the fix. Glad, this is solved for you. I'm closing this discussion. If you need further assistance or have questions you can re-open this discussion here or open a new one any time.

    Best, steve

  10. Steve closed this discussion on 29 Dec, 2014 08:28 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac