Cannot Export and Import keys

jsfrederick's Avatar


20 Nov, 2014 11:31 PM

GPG Keychain 1.2b1 (940b)

I have two Machines, both running 10.10.1. I just rebuilt one of my machines. I tried to export my keychain from the existing machine and import into the new machine.

I am able to export my keys (sec and pub) and import into the new machine. When I try to export the rest of the keys from GPG Keychain Access, I am able to export the keys fine. (followed the instructions in the knowledge base for backing up). When I copy that file to the new machine and try to export, I get NOTHING. No messages at all, and no keys imported.

I did try to export 1 key. And then two keys. When I import them, it works fine. Just not the entire list of my keys (except my own Pub an Sec keys).

Please describe what you did expect instead

I expected that I could export ALL of my keys into one file to import on my other machine.

  1. 1 Posted by Pascal on 20 Nov, 2014 11:39 PM

    Pascal's Avatar


    I have the same version and same build but OSX 10.10

    i cannot import or export any key

    i also tried with command line :
    gpg2 --verbose --import ./pascal.key

    get this answer : Illegal instruction: 4

    I tried to compile gpg2 from source, not luck :

    ./bin/brew: line 21: /Users/pascal/Downloads/MacGPG2/build/homebrew/Library/brew.rb: Undefined error: 0 Error: Build failed!
    make: *** [MacGPG2] Error 1

  2. 2 Posted by gavin on 21 Nov, 2014 01:21 PM

    gavin's Avatar

    I also can't import my keys on a newly built system

  3. Support Staff 3 Posted by Luke Le on 26 Nov, 2014 09:17 PM

    Luke Le's Avatar

    Hi Pascal,

    would you consider having a remote screen sharing session with us?
    We're currently trying to find a fix this error, but can't reproduce it ourselves.


  4. 4 Posted by Pascal on 26 Nov, 2014 09:58 PM

    Pascal's Avatar


    If that help, we could have screen sharing,
    on my desktop : it work
    on my laptop : still have the problem

    Don’t know why



  5. 5 Posted by jsfrederick on 26 Nov, 2014 10:45 PM

    jsfrederick's Avatar


    I can also do a screen sharing session with you as I am having the problem also. I can do Friday or Saturday. I am UTC-5.


  6. Support Staff 6 Posted by Luke Le on 26 Nov, 2014 10:53 PM

    Luke Le's Avatar


    @pascal: it would definitely help. what timezone are you in? would you have time tomorrow or the day after? @frederick: that would definitely be great. Could you just check for a gnupg crash log to make sure you have the same problem?


  7. 7 Posted by jsfrederick on 27 Nov, 2014 03:43 AM

    jsfrederick's Avatar


    Understood. I will pull the logs tomorrow and attach to this thread.

  8. 8 Posted by jsfrederick on 27 Nov, 2014 03:50 AM

    jsfrederick's Avatar

    Three GPG crash logs attached here. There are from my Macbook Pro Retina laptop. Will add the ones from my iMac tomorrow.

  9. 9 Posted by Pascal (LAP) on 27 Nov, 2014 12:51 PM

    Pascal (LAP)'s Avatar

    My time zone 181 UTC +1 (paris)

    Could be in 7 or 8 jours
    Or tomorrow around 2pm utc


  10. Support Staff 10 Posted by Luke Le on 27 Nov, 2014 01:02 PM

    Luke Le's Avatar

    Hi Pascal,

    tomorrow around 2pm sounds perfect!
    Could you come into our live chat around that time?


  11. Support Staff 11 Posted by Luke Le on 19 Dec, 2014 11:31 AM

    Luke Le's Avatar

    This bug is finally fixed in Beta 3 of GPG Suite.
    You can download Beta 3 from

  12. Luke Le closed this discussion on 19 Dec, 2014 11:31 AM.

  13. Luke Le re-opened this discussion on 19 Dec, 2014 04:55 PM

  14. Luke Le closed this discussion on 19 Dec, 2014 04:55 PM.

  15. jsfrederick re-opened this discussion on 19 Dec, 2014 07:31 PM

  16. 12 Posted by jsfrederick on 19 Dec, 2014 07:31 PM

    jsfrederick's Avatar


    Just installed Beta 3 and it is still NOT fixed for me.

  17. 13 Posted by jsfrederick on 19 Dec, 2014 07:48 PM

    jsfrederick's Avatar

    No messages in the Console. Here is the debug log.

  18. Support Staff 14 Posted by Steve on 19 Dec, 2014 08:49 PM

    Steve's Avatar

    JS, there might be an issue with one of the keys.

    Since you are not seeing anything in console or experiencing a crash, could you try to narrow down, which key is causing this problem?

    To do that, export the first half of your keys, try to import on your 2nd machine. If that works try the other half. Whenever you run into an issue, try and see if the other half of keys does import was as expected. Then split down further until you know which key is the problematic one.

    At the moment I suspect a key at fault. Let's see where this goes.

    Also please try using the latest nightly GPG Suite from there were quite afew MacGPG changes lately.

    All the best,

  19. 15 Posted by jsfrederick on 19 Dec, 2014 08:51 PM

    jsfrederick's Avatar

    Fair enough. I will work in that next week and let you know what I find.

    I'll try the nightly after I've narrowed it down to an individual key.


  20. Support Staff 16 Posted by Steve on 21 Dec, 2014 01:41 PM

    Steve's Avatar

    Or try the nightly directly to see if this is persisting and only then start the process of narrowing down.

    Just let us know your findings whenever you find the time to dig into this.

  21. Support Staff 17 Posted by Steve on 07 Jan, 2015 01:37 PM

    Steve's Avatar

    JS, did you ever get around to narrow down, which key might be causing the trouble?

  22. 18 Posted by jsfrederick on 07 Jan, 2015 02:53 PM

    jsfrederick's Avatar


    Yes, no, maybe…….

    Sort of. I did small groups of keys, about 5 at a time. Some of the groups worked fine, some didn’t. When I came across a group that did not import, I did each key individually. Some of the keys did not work. In some cases, I was able to import each key in a failed group without a problem.

    I dunno! Anyway, I now have most of the keys on my second machine.

    BTW, I tried this with the nightly as well as Beta 4 when it came out.

    Thanks for the assistance!

  23. Support Staff 19 Posted by Steve on 07 Jan, 2015 02:54 PM

    Steve's Avatar

    Feel free to attach any problematic public key and we can have a look what could be wrong there.

  24. Steve closed this discussion on 11 May, 2015 07:35 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac