GPGMail: Message not showing "Loading"

sjcjonker's Avatar

sjcjonker

03 Jul, 2017 04:30 PM

Hi,

Today I received two emails that once again kept "loading" for ever in Mail.app.

The first email is a forward, where below there is an piece of in-line PGP for which I don't hold the key.

The second one is the email, decrypted and resent with my key. But it also has the original message attached (the one I don't have the key for).

I have a feeling this is causing the "Loading" but not sure of course.

I did try to make a debug log via "defaults write org.gpgtools.common DebugLog 1" but in "console" I couldn't find anything PGP / GPG like, except:
SandboxViolation: Mail(17728) deny file-write-unlink /Users/sjcjonker/.gnupg/gpg-agent.conf

So I didn't attach the output of console, happy to provide (redacted) logs if needed. Happy to send, but I would need to redact any partially decrypted content. As such didn't set the checkmark, and send without logs.. SORRY guys. If you let me know what to gather, I'll redact and attach to the ticket.

Stijn

Expected
The message loaded with an decrypt error, or partial decrypt.

macOS           10.12.5     16F73
GPG Suite       2017.1b3    1812    (d43863c)
GPGMail         2.7b3       1215    (d0b5fa0)
GPG Keychain    1.3.3b2     1271    (028a4a2)
GPGServices     1.11        916     (872e77d)
MacGPG2         2.0.30-1b2  887-    (4912d26)
GPGPreferences  2.0.2b3     927     (641418e)
Libmacgpg       0.7         782     (536bf51)
pinentry        0.9.7       4       (b75069d)
  1. Support Staff 1 Posted by Steve on 05 Jul, 2017 01:15 PM

    Steve's Avatar

    Hi sjcjonker,

    could you please download and install our latest GPG Suite nightly build and see if the problem persists. That page also has sig and SHA256 to verify the download.

    All the best,
    steve

    Disclaimer: This is a development version which has not been thoroughly tested yet - bugs or crashes are to be expected. Thanks for helping us test.

  2. 2 Posted by sjcjonker on 05 Jul, 2017 05:46 PM

    sjcjonker's Avatar

    Hi Steve,

    Indeed it now shows the messages that it was previously stuck at the "loading". But also it seems the emails that worked previously ok, are actually showing faster. (Not timed/proven, just a feeling).

    So for me this seems to fix "my" issue. I'll keep using this in the coming days (until the next official release). I'll raise an item if I find something very odd or wrong.

    If so, would you guys like me to re-open this ticket, or a new one?

    Thx,
    Stijn

  3. Support Staff 3 Posted by Steve on 05 Jul, 2017 05:50 PM

    Steve's Avatar

    Stijn, both options are fine. A new discussion always may be the best option to start with a clean slate.

    Please observe the behavior. There have been some big changes under the hood: gpg 2.1, libgcrypt 1.7.8 and libmacgpg improvements.

    Closing this as the issue is solved with the nightly build.

    Kind regards,
    steve

  4. Steve closed this discussion on 05 Jul, 2017 05:50 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac