Decryption Issues

Simply Prince's Avatar

Simply Prince

19 Jun, 2017 04:15 PM

Which of our tools is giving you problems?

  • Current Version (went back to the standard beta after I read the email I'm having an issue with) :
    • macOS: 10.12.5 build:16F73
    • GPG Suite: 2017.1b3 1812
    • GPGMail: 2.7b3 1215
    • GPG Keychain: 1.3.3b2 1271
    • GPGServices: 1.11 916
    • MacGPG2: 2.0.30-1b2 887-
    • GPGPreferences: 2.0.2 959n
    • Libmacgpg: 0.7 782
    • pinentry: 0.9.7 4

I will add screenshots

Describe your problem. Add as much detail as possible. Hey Team, the issue is odd. I'm running the latest beta and I get an email from a coworker from another team. I had to download the nightlites to get the email to decrypt.

  • What Worked (nightlies version):
    • macOS: 10.12.5 build:16F73
    • GPG Suite: 2017.1 1900n
    • GPGMail: 2.7 1219n
    • GPG Keychain: 1.3.3 1338n
    • GPGServices: 1.11 945n
    • MacGPG2: 2.0.30 891n
    • GPGPreferences: 2.0.2 959n
    • Libmacgpg: 0.8 803n
    • pinentry: 0.9.7 20n

So I emailed her and asked her for her version of GPGTools and heres what she sent me:

  • GPG Tools For CoWorker:
    • macOS 10.10.5 14F2109
    • GPGSuite 2016.10 21
    • GPGMail 2.6.2 1169
    • GPG Keychain 1.3.2 1245
    • GPGServices 1.11 916
    • MacGPG2 2.0.30 884
    • GPGPreferences 2.0.1 902
    • Libmacgpg 0.7 775
    • pinentry 0.9.7 4

What did you expect instead

I expected my Mail.app to show the email decrypted but instead it showed me two files: PGPMIME... and encrypted. You can open the encrypted file by dragging to desktop, right-click / services / OpenPGP: Decrypt File (same way we were handling files during the beginning of the SierraCrap). Again, after installing nightlies on 06.14.2017 it worked fine.

Are you using any other Mail.app plugins? not at all =)

- Thank you team as always. There is no rush at all. I'm more so curious as to why this is happening. We have informed folks to install the nightlies to correct the issue when they got it, but wondering if we might be missing the solution. Also wonder what the issue is - if its clear.

  1. Support Staff 1 Posted by Steve on 19 Jun, 2017 04:28 PM

    Steve's Avatar

    Hey Prince,

    thanks for another thorough report. This issue is caused by email messages going through an MS exchange server. We made GPGMail more tolerant and the fix is already in the nightly. The fix will be released with the next beta. So whenever you are seeing this problem, installing the nightly will resolve it.

    Please note that the nightly comes with gpg 2.1 and keys created using that version will require additional steps when going back to gpg 2.0.x.

    Since the bug is on the receiving end it doesn't really matter which version the message author is using.

    Let me know if that makes sense.

    Kind regards,
    steve

  2. 2 Posted by Simply Prince on 19 Jun, 2017 04:40 PM

    Simply Prince's Avatar

    You folks are, as usual: Simply Amazing!!
    Thank you. And, yes, it must be the darn MSExchange. This is one of our sister-companies so they have a different IT structure, team and all that good stuff.

    Thanks again and this makes good sense. I've pushed it to my team so they are in the know as well. Feel free to close this out on my end, =)

  3. Steve closed this discussion on 19 Jun, 2017 04:43 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac