GPGTools can't find my keys - Keys are working in Linux

M Martin's Avatar

M Martin

26 May, 2017 07:49 PM

Hello. I have a Macbook Pro running Sierra and have installed GPGTools 2017.1b3. I've read the guides and FAQs but can't seem to solve my usability problems with GPGTools. I've also read Jerzy's best PGP/MacOS X tutorial which is quite excellent! When I use GPG Keychain to create test keys from scratch everything works perfect. However:

  1. I have a current PUB/SEC key pair I use on my Linux workstation and servers running GnuPG 2.1.11. Everything is working as expected.
  2. I copied my ~/.gnupg/ folder to my User's directory on this MacBook Pro.
  3. I installed Brew and then installed GnuPG from Brew and everything is working as expected. File and Dir ownerships are correct.
  4. I next installed GPGTools and the GPGPreferences say under Default Key: "No key found"
  5. GPG Keychain shows my PUB keys but nothing else
  6. When I open a terminal to run a CLI signature, I get the following message:
    gpg -o 1.asc -u 0x4Bxxxxxxxxxx --clearsign 1.txt
    gpg: skipped "0x4BExxxxxxxxxxxxxxx: No secret key
    gpg: 1.txt: clearsign failed: No secret key
  7. When I run gpg --list-keys and gpg --list-secret-keys everything is where it should be.
  8. I uninstall GPGTools and the command in #6 works perfectly with the Brew version of GPG.

I'm not using any programs. I normally just write the emails I want to sign in a text file, clear sign or encrypt, and cut-and-paste into email. That's what I've done with my Linux workstation for nearly 20 years now.

"echo $GPGHOME" returns now value.

I know I'm not doing this right, I've just lost sight of where I've misconfigured all this. I'd like to use the keyboard short cuts listed in Jerzy's tutorial, but can't get PGPTools configured correctly yet. Any pointers would be appreciated.

Thank you for looking,

  1. Support Staff 1 Posted by Steve on 29 May, 2017 12:38 PM

    Steve's Avatar

    Hi Martin,

    welcome to the GPGTools support platform. Sorry you are having problems using GPG Suite.

    The situation you are seeing is the following. You created your OpenPGP keys with gnupg 2.1.x on linux. Then transferred your keys to macOS. GPG Suite comes with gnupg 2.0.x and since the keys are not downward compatible you are running into the situation you described.

    We are internally testing gnupg 2.1 and will soon offer a nightly build that comes with 2.1.

    Should you need your keys urgently:

    GPG Suite is not ready for usage with gpg 2.1.x.

    You need to export your sec/pub key which was created with 2.1. In order to do that, 2.1 has to be installed on your system, so you may have to re-install 2.1 in case it was uninstalled. Ensure there is a password set for all secret keys created under 2.1. After that, please export the secret keys:

    open and paste the following command:

    gpg2 -a --export-secret-keys > ~/Desktop/secret_keys.asc

    Please do not deleted anything. Then uninstall 2.1 and using 2.0.30 re-import the exported file to GPG Keychain.

    Let me know if this worked.

    All the best,

  2. Support Staff 2 Posted by Steve on 13 Jun, 2017 08:46 PM

    Steve's Avatar

    Hi Martin,

    we have a first GPG Suite test build which integrates gpg 2.1. Here is the signature file for that release.

    It would be great if you could test this build and let us know if run into any trouble. Please note, that downgrading to the current beta release will require additional steps in case new keys were created using this test build. Depending on the test results, gpg 2.1 may soon land in the beta branch.

    All the best,

  3. 3 Posted by MMartin on 14 Jun, 2017 03:32 PM

    MMartin's Avatar


    Installed and reloaded my GnuPG 2.1.X keys and all appears to be working again on the MacOS side of things.

    I appreciate the hard work you put into this project. A donation is headed your way. :)



  4. Support Staff 4 Posted by Steve on 14 Jun, 2017 03:49 PM

    Steve's Avatar

    That's good news. And thanks a lot for your support - it's appreciated.

    If you run into any trouble using gpg 2.1, please re-open or file a new discussion.

  5. Steve closed this discussion on 14 Jun, 2017 03:49 PM.

  6. Steve closed this discussion on 18 Jun, 2017 05:30 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac