Can't import keys (public and private)

Sandra's Avatar


12 Nov, 2014 12:21 PM


I use the beta and ne new build of gpg Mail. Now all of my keys (public and private) are gone. I tried to import a backup (*.asc) with alle of the keys, but i woun't work. There is no error shown up or something else. I've tried to import via drag & drop and via the import button. Also un- and re-installed the whole package.

Please Help!!!


  1. 1 Posted by Sandra on 12 Nov, 2014 01:46 PM

    Sandra's Avatar

    So, now i've imported some new keys without problems. when I try to export the key there are no problems, but exporting the private key it failed. there is no new *.asc created.

  2. Support Staff 2 Posted by Luke Le on 14 Nov, 2014 12:30 AM

    Luke Le's Avatar

    Hi Sandra,

    the chances are very good that the keys are not gone at all, but that there's some kind of permission problem in play.

    Are you familiar with Terminal on OS X?

  3. 3 Posted by Julian on 08 Jan, 2015 01:39 PM

    Julian's Avatar

    Same here. I want to move my keychain over to a new Mac so I created an .asc file using GPG Keychain's export feature and importing that file on the new machine.
    I don't get any message telling me whether the process was successful or not instead nothing's imported - nothing shows up.
    I read in the forums there's a way to try and import .asc files via Terminal? Let me know what I need to do for that and I'll give it a try.

  4. Support Staff 4 Posted by Luke Le on 06 Feb, 2015 04:00 PM

    Luke Le's Avatar

    Hi Julian,

    to import it via the Terminal, best save the .asc file to your Desktop and run the following command:

    gpg --import ~/filename.asc

    Replace "filename" with your filename.

  5. 5 Posted by Julian on 23 Mar, 2015 10:32 AM

    Julian's Avatar

    Thanks Luke!
    I eventually succeeded by exporting smaller batches of my keys in multiple files.

  6. Support Staff 6 Posted by Steve on 23 Mar, 2015 10:56 AM

    Steve's Avatar

    Julian, were you able to detect, if there was a specific key causing the trouble or did all keys import fine that way?

    @Sanrda: where you able to get your issue solved or do you still need assistance?

  7. Support Staff 7 Posted by Steve on 03 Jun, 2015 01:16 PM

    Steve's Avatar

    Closing, since no further user feedback was received. Should your problem persist, feel free to re-open this discussion any time.

    All the best, steve

  8. Steve closed this discussion on 03 Jun, 2015 01:16 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac