GPGMail on El-Capitan

Neil Cook's Avatar

Neil Cook

03 Nov, 2015 04:26 PM

GPGMail 2.6b2 (1105b)

I see GPGPreferences in System Preferences, however I don't see an icon for GPGMail in preferences. No sign that the plugin is installed in I'm using OX X 10.11.0.

What did you expect instead

I expect to see the GPGMail icon in Mail preferences, and the lock icon when I compose a message.

Describe steps leading to the problem.

  1. Install GPGSuite
  2. Be underwhelmed by the lack of any GPGMail features in

No other plugins

  1. 1 Posted by David Collantes on 04 Nov, 2015 06:58 PM

    David Collantes's Avatar

    Quit Re-install GPGTools, make sure you use default install, which includes plugin. Try. If still doesn't show, restart. Try. If still doesn't show, open console and search for gpg. You should see Loaded GPGMail 2.6b2 or similar.

    Other than that, I don't know. Make sure you do not have conflicting gpg installs (brew plus GPGTools, for example) and that you have not added anything odd to gpg.conf or gpg-agent.conf.

  2. Support Staff 2 Posted by Luke Le on 04 Nov, 2015 07:00 PM

    Luke Le's Avatar

    Hi Neil, David,

    @David: thanks for chiming in! :)

    @Neil: very sorry you're experiencing troubles. Could you please run the following commands in Terminal and post the output:

    ls -ld /Library/Mail/Bundles/GPGMail.mailbundle
    defaults read EnableBundles


  3. 3 Posted by Neil Cook on 04 Nov, 2015 07:33 PM

    Neil Cook's Avatar

    @David: I did try restarting, but that didn't fix it.

    @Luke: Ok, so:
    % defaults read EnableBundles 0

    So I did:
    defaults write EnableBundles -bool YES
    sudo defaults write EnableBundles -bool YES

    And now it works! Thanks for the hints! I'm not sure why EnableBundles was 0 - shouldn't the installation set that to 1?

  4. Support Staff 4 Posted by Luke Le on 05 Nov, 2015 11:55 AM

    Luke Le's Avatar

    Hi Neil,

    very happy to hear it's working now.
    The installer does set EnableBundles to 1 but in very few cases it doesn't take.
    Unfortunately we have yet to figure out why.

  5. Steve closed this discussion on 05 Nov, 2015 04:51 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac