hangs on launch with GPGTools 2.5b6

dieter's Avatar


14 May, 2015 02:33 PM


after using gpgtools 2.5b6 with without problems for a while, since a couple of days freezes at launch. At first I thought it is a bug, but after removing the GPGMail.mailbundle it worked again.

A sample during the hang also points to gpgtools (shortend):

 2862 +[GPGController initialize]  (in Libmacgpg) + 64  [0x10ba5bc3f]
   2862 +[GPGTaskHelper pinentryPath]  (in Libmacgpg) + 98  [0x10ba5423d]
     2862 dispatch_once_f  (in libdispatch.dylib) + 117  [0x7fff89830b26]
       2862 _dispatch_client_callout  (in libdispatch.dylib) + 8  [0x7fff89830c13]
         2862 __29+[GPGTaskHelper pinentryPath]_block_invoke  (in Libmacgpg) + 90  [0x10ba56d50]
           2862 -[GPGOptions valueForKey:inDomain:]  (in Libmacgpg) + 137  [0x10ba46b66]
             2862 -[GPGOptions valueInGPGAgentConfForKey:]  (in Libmacgpg) + 27  [0x10ba47831]
               2862 -[GPGOptions gpgAgentConf]  (in Libmacgpg) + 135  [0x10ba47db3]
                 2862 -[GPGConf initWithPath:andDomain:]  (in Libmacgpg) + 200  [0x10ba4e041]
                   2862 -[GPGConf loadConfig]  (in Libmacgpg) + 53  [0x10ba4d914]
                     2862 -[GPGConf loadConfigFileXPC]  (in Libmacgpg) + 78  [0x10ba4def6]
                       2862 -[GPGTaskHelperXPC loadConfigFileAtPath:]  (in Libmacgpg) + 171  [0x10ba58808]
                         2862 -[GPGTaskHelperXPC waitForTaskToCompleteAndShutdown:throwExceptionIfNecessary:]  (in Libmacgpg) + 43  [0x10ba58452]
                           2862 _dispatch_semaphore_wait_slow  (in libdispatch.dylib) + 213  [0x7fff89837c55]
                             2862 semaphore_wait_trap  (in libsystem_kernel.dylib) + 10  [0x7fff880b351a] Version 8.2 (2098)
Mac OS X 10.10.3 (14D131)

I can provide the full sample log if needed.


  1. 1 Posted by Gabriel Rosenko... on 22 May, 2015 02:50 AM

    Gabriel Rosenkoetter's Avatar

    I ran into this same problem today, with the same symptoms in the stack trace when was force quit.

    When I tried to run the Uninstall app that came with the program (felt cleaner than manually removing bundles to me), it hung in the same way, which made me wonder whether there were some GPGTools-related processes still running, and there was:

    /Library/Application Support/GPGTools/org.gpgtools.Libmacgpg.xpc

    ... as well as a gpg-agent --daemon and /usr/local/MacGPG2/libexec/shutdown-gpg-agent (I'm not sure whether the latter was triggered by the uninstall attempt, as I hadn't checked ps(1) first).

    Killing the instance of org.gpgtools.Libmacgpg.xpc that had been running in the background for ~20 days corrected the issue, and the XPC service ( immediately comes back and seems to function normally the next time any GPGTools component gets touched.

    I can't now reproduce the problem easily, but it sounds like Dieter and I both have force-quit stack traces if they'd be helpful to debug the problem.

  2. 2 Posted by dieter on 22 May, 2015 07:17 AM

    dieter's Avatar

    Gabriel, I was wondering if this is the same issue as discussed here:

    So maybe the issue is already resolved in the nightly build. I didn't try it yet though.

  3. 3 Posted by dieter on 22 May, 2015 07:21 AM

    dieter's Avatar

    Ah, I just saw Beta 6 was just released which seems to contain the fix described in the discussion linked above:

  4. 4 Posted by Jon G on 02 Jun, 2015 05:49 PM

    Jon G's Avatar

    Same exact issue here, with 2.5b6 (3/18). wouldn't quit, stopped responding, and I had to force quit. After that, it wouldn't relaunch until I removed the GPGMail bundle from /Library/Mail/Bundles.

  5. Support Staff 5 Posted by Steve on 21 Jul, 2015 10:03 PM

    Steve's Avatar

    Hi all,

    first, thanks for taking the time to report this problem and sorry for the slow response.

    Since we fixed a crash in regards to GPGTaskHelper, could you please download and install our latest nightly build and see if the problem persists. That page also has sig and SHA1 to verify the download.

    All the best, steve

    Disclaimer: This is a development version which has not been thoroughly tested yet - bugs or crashes are to be expected. Thanks for helping us test.

  6. Steve closed this discussion on 26 Nov, 2015 10:43 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac