1. Installing GPG tools manually (without Install.pkg) and 2. building from source on 10.10 without Ruby 1.8

UY's Avatar


11 Apr, 2015 09:35 PM

How can I install GPG tools manually? I'm always scared when giving any app (Install.pkg in this case) root access. I would rather type in the required Terminal commands myself using sudo.

Please show me how.

  1. 1 Posted by UY on 12 Apr, 2015 07:31 AM

    UY's Avatar

    Ok so I tried building it manually from the source code but it doesn't work on Yosemite. This exact issue occurs:


  2. 2 Posted by UY on 12 Apr, 2015 07:32 AM

    UY's Avatar

    That one is from January 2015. It's because Yosemite doesn't have Ruby 1.8.

    Any plans to address this?

  3. 3 Posted by UY on 12 Apr, 2015 09:40 AM

    UY's Avatar

    I tried compiling MacGPG manually.

    Well it seems I can install ruby 1.8 through homebrew and change the top line of the .rb file in the MacGPG2 folder.

    But then brew starts complaining because it doesn't know what compiler goes with Xcode 6.3. I also tried Xcode 6.2 but no go. So maybe the problem is with homebrew.

    Anyone been successful here compiling MacGPG on Xcode 6.3, OS X 10.10.3?

  4. Support Staff 4 Posted by Steve on 24 Feb, 2016 12:09 PM

    Steve's Avatar

    Hey UY,

    welcome to the GPGTools community support platform. Sorry you are having problems using GPG Suite.

    Please excuse the insanely slow response. This one slipped through the cracks, sorry!

    We have a ticket for this problem. I connected this discussion with the existing ticket. That means, should this discussion get closed, it will be re-opened as soon as the ticket is closed. That way you'll stay in the loop and get notified as soon as we have news. Feel free to open a new discussions should you run into further problems or need assistance.

    All the best,

  5. Steve closed this discussion on 24 Feb, 2016 12:09 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac