GPG Services: Enable passphrase for each encryption

simon hanslip's Avatar

simon hanslip

26 Apr, 2019 01:01 PM

Which of our tools is giving you problems?

GPG Keychain

Attach a screenshot of the version info for all installed components (how to: https://gpgtools.tenderapp.com/kb/faq/where-can-i-find-version-info...):

Version 1.4.6 (1514)

Describe your problem. Add as much detail as possible. When I decrypt it does not ask for passphrase it just decrypts automatically, I want to have to input passphrase each and every time I decrypt a message.

What did you expect instead

To be asked for passphrase every time I decrypt.

Describe steps leading to the problem.

Are you using any other Mail.app plugins? No

  1. Support Staff 1 Posted by Steve on 29 Apr, 2019 03:26 PM

    Steve's Avatar

    Hi Simon,

    welcome to the GPGTools support platform. Sorry you are having problems using GPG Suite.

    This sounds like your password may have been stored in macOS keychain or that caching time is active.

    Should you prefer, to not store the password for your OpenPGP key in macOS keychain, you can change this setting in System Preferences > GPG Suite > Settings. You can also disable the caching time at that place. The Delete… button deletes both cache and stored OpenPGP Passwords.

    Let me know if that worked.

    Best,
    Steve

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac