GPG Keychain: Cannot export my private key

menkalinan56's Avatar


04 Apr, 2019 08:42 AM

I am using GPG Keychain 1.4.6 on macOS Mojave (10.14.4). This is part of the GPG Suite 2018.5 (2368).
I wanted to back up my key using the export function. If I choose to include the private key as well I get an error message after about 30 secs (see screenshot attached). However, exporting the public key only works fine.

Your help will be much appreciated!

  1. Support Staff 1 Posted by Steve on 05 Apr, 2019 03:12 PM

    Steve's Avatar

    Hi Andreas,

    welcome to the GPGTools support platform. Sorry you are having problems using GPG Suite.

    Could you restart your mac and let me know if then the problem persists for you?


  2. 2 Posted by menkalinan56 on 08 Apr, 2019 03:25 PM

    menkalinan56's Avatar

    Hi Steve,
    thank you for your help. Your suggested solution solved my problem. I could export my keys successfully.


  3. Support Staff 3 Posted by Steve on 08 Apr, 2019 04:29 PM

    Steve's Avatar

    Glad this is solved for you. I'm closing this discussion. Should you need further assistance or have questions you can re-open this discussion here or open a new one any time.


  4. Steve closed this discussion on 08 Apr, 2019 04:29 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac