GPG Services: Decryption failed no data code = 58 when trying to decrypt a message in word doc format

Josh's Avatar

Josh

04 Mar, 2019 10:21 PM

This comment was split from the discussion: Decryption failed no data code = 58

Hello,

I am having this same problem with word. I encrypted some sensitive information a while ago and saved it to a word doc. When I went to decrypt and retrieve it, it get a message saying: Decryption Failed: No Data! (No data) Code = 58.

I tried writing a random message in the same Word doc, which I was able to encrypt with my key, but not decrypt using the same key. However, using Mac Notes, I was able to successfully encrypt and decrypt a message using the same key.

Can you help?

Josh

  1. Support Staff 1 Posted by Steve on 04 Mar, 2019 10:26 PM

    Steve's Avatar

    Hi Josh,

    welcome to the GPGTools support platform. Sorry you are having problems using GPG Suite.

    The problem is, that Word is formatting text and by that altering things. The following is an explanation about RTF file format usage for OpenPGP. The same applies to the Word DOC format:
    The key / message you are trying to import / decrypt is in RTF file format. Wikipedia says: "The Rich Text Format (often abbreviated RTF) is a proprietary document file format developed by Microsoft Corporation from 1987 until 2008 for cross-platform document interchange with Microsoft products."

    RTF is formatted text and the problem with formatted in case of OpenPGP messages is, it tends to destroy their structure and render them useless.

    To exchange OpenPGP messages please use .txt file format. For keys you can use the key servers or if that is not an option also use .txt or .asc file format.

    So you did the right thing by switching to a text editor. I would recommend using TextEdit and checking in the preferences you are using txt format.

    Best,
    Steve

  2. 2 Posted by laggardkernel on 24 May, 2019 07:42 AM

    laggardkernel's Avatar

    This comment was split into a new discussion: GPG Services: Decryption failed no data code = 58 when trying to decrypt a message in word doc format

    This didn't alleviate my problem. After copying the encrypted text to a text editor (TextEdit or Sublime), the decryption still failed with the same error.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac